Hi, I’m using the OSMC DVB-T2 stick on a pi3 and have a couple of quick questions.

  1. I’m currently using the latest Leia Alpha release…is there a downside to this and TV Headend? The reason I ask is because the two Panasonic devices in ‘TV Adapters’ keep disappearing, leaving just the Realtek one, I’m not sure if this is normal behaviour or not, and the only way I can get them to reappear is to uninstall/reinstall TVHE.
    Wondering if there were any known issues with using the DVB stick on an Alpha release.

  2. Do I need the mpeg license on the Pi that TV Headend is running on?..im not using this to view any Live TV, I use other Kodi clients around the house for this, none of which are Pis.


Try clear the ~/.hts directory.

No – if you’re not watching MPEG2 on that device, there is no benefit of having the license.

Cheers Sam.

Hi Sam, I’ve got it working really well now, loads of channels tuned in and working, but this issue happens on every reboot.

Is there a way around ditching the entire ~/.hts folder as that causes me to have to go through the entire setup process on every reboot, which is a bit of a PITA…especially as I plan to use the recording function quite a lot for when I’m away from home, and any planned recordings will be deleted.

Ive tried cold booting as well as unplugging the DVB stick as well but that makes no difference.

Could this be a faulty stick?

Well I’ve stumbled across a way which saves deleting the entire ~/.hts folder…not sure if its recommended, but if I stop the TVHE service, delete the contents of /dev/dvb/adapter0 then reboot, the Panasonic devices reappear, then if I re-enable them through the TVHE web interface they are working again…not ideal but its a workaround for now.

It’s unlikely to be a faulty stick and more likely to be a TVHeadend bug. I’ll see if I can reproduce

Upon further messing around, when the issue occurs, simply disabling the Realtek device through the TVHE web interface, then rebooting, makes the Panasonic devices reappear…they need to be re-enabled after but this workaround saves having to delete anything from terminal.

Im getting the same issue on a Pi2 with the latest stable OSMC build, and on a Pi 3 with the latest Leia Alpha…the only things in common are the stick and TVHE so I think you’re probably correct about a TVHE bug.

There’s no point in enabling both tuners. you can’t use them at the same time and the panny does all that the realtek does (and more).

Ive disabled the Realtek (and also the Panasonic DVB-C as I have no use for that) and its solved the problem completely for me, its survived about 5 reboots now and every time the Panasonic device is fully operational, excellent suggestion sir!

When you say the panny does all the Realtek and more, do you mean DVB-T & DVB-T2 ?

Yes. The realtek does only DVB-T, not T2 or C.