DVD Autoplay not working correctly

I have DVD autoplay enabled. When I insert a DVD, instead of playing, it brings up a file menu:

DVD Title

Browse videos
Browse music
Browse pictures
Browse files

When I select the first video file, the DVD will play just fine.

The section of log that appears when I insert the disc is

18:41:16 2586.892822 T:3023389232   DEBUG: ------ Window Deinit (DialogKaiToast.xml) ------
18:41:21 2592.175781 T:3004249120    INFO: Detecting DVD-ROM media filesystem...
18:41:21 2592.196777 T:3004249120    INFO: CD Analysis Report
18:41:21 2592.198730 T:3004249120    INFO: __________________________________
18:41:22 2593.033447 T:3004249120    INFO: CD-ROM with ISO 9660 filesystem
18:41:22 2593.036865 T:3004249120    INFO: ISO 9660: 1151849 blocks, label
18:41:22 2593.040771 T:3004249120    INFO: Tracks overall:1; Audio tracks:0; Data tracks:1
18:41:22 2593.414551 T:3004249120    INFO: Using protocol iso9660://
18:41:22 2593.416016 T:3004249120    INFO: Disc label:
18:41:25 2595.850830 T:2680157216  NOTICE: Thread JobWorker start, auto delete: true
18:41:25 2595.862793 T:3023389232   DEBUG: ------ Window Init (DialogSelect.xml) ------
18:41:30 2601.382568 T:3003118624   DEBUG: CAESinkPi:Drain delay:99ms now:0ms
18:41:40 2611.384521 T:3003118624   DEBUG: CAESinkPi:Deinitialize
18:41:40 2611.386963 T:3003118624   DEBUG: CAESinkPi:SetAudioProps hdmi_stream_channels 0 hdmi_channel_map 00000000
18:41:40 2611.403809 T:3003118624   DEBUG: COMXCoreComponent::Deinitialize : OMX.broadcom.audio_render handle 0x427c4a8

I assume this isn’t what’s meant by DVD autoplay.

I’m running OSMC Kodi-RC1 Git:Unknown (Compiled Aug 7 2015) on a Raspberry Pi Model B+.

Here’s the full log: http://paste.osmc.io/zivacukuti

I think you’ll find the issue is that your “DVD” does not have a UDF file system, only an iso9660 file system:

18:59:38  94.855484 T:2874442784    INFO: Detecting DVD-ROM media filesystem...
18:59:38  94.874443 T:2874442784    INFO: CD Analysis Report
18:59:38  94.878418 T:2874442784    INFO: __________________________________
18:59:39  95.619774 T:2874442784    INFO: CD-ROM with ISO 9660 filesystem
18:59:39  95.620216 T:2874442784    INFO: ISO 9660: 1151849 blocks, label
18:59:39  95.620674 T:2874442784    INFO: Tracks overall:1; Audio tracks:0; Data tracks:1
18:59:39  96.012543 T:2874442784    INFO: Using protocol iso9660://
18:59:39  96.012970 T:2874442784    INFO: Disc label:

Data CD’s normally have only an iso9660 file system while DVD’s have a UDF file system, sometimes with an optional iso9660 file system.

Although I would have to double check, I think you’ll find that Kodi will only auto-play a DVD with a UDF file system, disks with iso9660 file systems are assumed to be data discs not DVD-Movie disks, hence the prompt to ask you what to do with the disk.

Have you tried any other DVD’s ?

I just tried several DVDs. They all show output very similar to the above, with Using protocol iso9660://.

Check PM, I am keen to replicate this issue and if you can send us a sample that will help.


OK, I have done. Thanks!