Empty video addons list

After august update my video addon list is empty.
The addons are still there. I can use them from the favorites list.
But the video addon list is empty.

I checked my log to see if any error popped up and I got this error on all my addons:

23:04:32 31.055586 T:1438643184 ERROR: Couldn’t load /home/osmc/.kodi/addons/service.library.data.provider/1080/Font.xml

I changed skin to confluence and back to osmc’s skin but the addon list is still empty.

Tried to search for similar issues here and on google but no luck :frowning:

That error is unrelated. Please provide a complete set of logs.

Check for updates. I suspect your system isn’t fully updated.

My OSMC -> Manual Controls -> Updates -> Check for Updates now.

Just checked. My Osmc says there’s nothing to update.
What are the commands to force a command line update?
What logs do you need? just kodi.log?

grab-logs -A

As @ActionA says, you need to provide a full set of logs.

Here they are:

ii rbp2-mediacenter-osmc 16.1.0-19 armhf Media Center package for OSMC

Your system is not up to date. The correct version should be 16.1.0-20. Check for updates again, and also check your network connection. If you’re on WiFi, try an Ethernet cable temporarily.

You can also update via the command line with sudo apt-get update && sudo apt-get dist-upgrade


Got it to update and the problem’s solved!
Thanks for the help @sam_nazarko and @ActionA