Enable Debug Logging No Longer Showing in Settings/System/Debugging


I just upgraded to the latest OSMC release (with Kodi 15). My system kept crashing as my PVR channels and EPG were loading so I disabled it.

I want to enable logging before enabling it again but when I go to Settings/System/Debugging it no longer displays the item “Enable Debug Logging”. I’ve tried different skins, thinking perhaps it would show it in one of them, but no luck.

Instead I see the following:

Enable component-specific logging

  • Specify component-specific logging
    Screenshot folder
    Reset above setting to default.

How can I enable logging so that I’ll be able to send details on why my system keeps crashing during PVR loading?

This has only begun to happen since the upgrade.

As always, your help is gratefully appreciated.



Make sure you are in Expert mode - if Kodi has crashed repeatedly it may have corrupted guisettings.xml which will put many of your settings back to defaults, including putting you back in Standard mode.

I am in Expert mode. I’ve checked for the Enable Debug Logging item in Expert mode in OSMC, Confluence and other skins.

Can you take a screenshot of the page with the missing setting ?

One other thing to check - you don’t have an option enabling or disabling debugging in advancedsettings.xml do you ? If you do this can cause the option to be hidden in the GUI.

I seem to have fixed the problem.

I added the following to my advancedsettings.xml file:


Then I restarted OSMC. I checked Settings and I can now see the option to enable debug logging.

However, I don’t see the kodi.log file. Where should it be? Under /home/osmc or /home/osmc/kodi? I’ve checked both locations and it isn’t there.

Thanks, K.

If you just added the number 1 to your advancedsettings.xml you have caused a syntax error, thus the rest of the file (including the line causing the problem) now gets ignored. What was the rest of the contents of the file ?

Debug log is at /home/osmc/.kodi/temp/kodi.log

I pasted the advancedsettings entry correctly but it didn’t display correctly because I didn’t select the preformatted text button first.

It is:

<loglevel hide="true">1</loglevel>

I found the log file. Thanks again for your help!


If you force a guisetting in advancedsettings (like loglevel) then the gui setting won’t show. This is expected behaviour.