Enabling tv in kodi causes OSMC to crash

I cant get TV enabled (where it asks me my tvheadend service IP), every time I try to enable TV, after I select the correct IP address, OSMC crashes, then never allows me to access any TV, says cant connect.

I have configured tvheadend, added all my local channels. I have 2 tvheadend servers on the network, both show up however after I try to add my local one, it no longer shows up any more.

This is a fresh install, January build. I cant seem to get anything to work, the December build was a complete disaster.

I assume there is a log or something somewhere I can post?

To get a better understanding of the problem you are experiencing we need more information from you. Please see http://osmc.tv/wiki/general/how-to-submit-a-useful-support-request/ for advice on how to help us.

Well I would recommend either to check your hardware or maybe watch what addons you install as the december build wasn’t a disaster for thousand of other users.

Logs are here…
http://paste.osmc.io/loqocagure

Kodi says…
16:38:13 93.886848 T:1742468128 NOTICE: Autoconfigure - auto-configured Tvheadend #2 using host ‘192.168.1.45’ and port ‘9982’

Then nothing (crashes after that)

Maybe something to do with this???

[ 772.867126] usb 1-1.4: dvb_usb_v2: usb_bulk_msg() failed=-19
[ 772.867172] af9033 3-0038: i2c rd failed=-19 reg=800047 len=1
[ 775.867102] usb 1-1.4: dvb_usb_v2: usb_bulk_msg() failed=-19
[ 775.867145] af9033 3-0038: i2c rd failed=-19 reg=800047 len=1
[ 778.867096] usb 1-1.4: dvb_usb_v2: usb_bulk_msg() failed=-19
[ 778.867141] af9033 3-0038: i2c rd failed=-19 reg=800047 len=1
[ 781.867080] usb 1-1.4: dvb_usb_v2: usb_bulk_msg() failed=-19
[ 781.867126] af9033 3-0038: i2c rd failed=-19 reg=800047 len=1
[ 784.867078] usb 1-1.4: dvb_usb_v2: usb_bulk_msg() failed=-19
[ 784.867120] af9033 3-0038: i2c rd failed=-19 reg=800047 len=1
[ 787.867124] usb 1-1.4: dvb_usb_v2: usb_bulk_msg() failed=-19
[ 787.867168] af9033 3-0038: i2c rd failed=-19 reg=800047 len=1
[ 790.867079] usb 1-1.4: dvb_usb_v2: usb_bulk_msg() failed=-19
[ 790.867123] af9033 3-0038: i2c rd failed=-19 reg=800047 len=1

I would say maybe more with this

[  240.347084] INFO: task kworker/0:1:31 blocked for more than 120 seconds.
[  240.347120]       Tainted: G         C      4.4.0-1-osmc #1
[  240.347132] "echo 0 > /proc/sys/kernel/hung_task_timeout_secs" disables this message.
[  240.347145] kworker/0:1     D 8074c63c     0    31      2 0x00000000
[  240.347197] Workqueue: usb_hub_wq hub_event
[  240.347241] [<8074c63c>] (__schedule) from [<8074cc80>] (schedule+0x5c/0xcc)
[  240.347322] [<8074cc80>] (schedule) from [<7f15bbf4>] (dvb_unregister_frontend+0xf4/0x12c [dvb_core])
[  240.347401] [<7f15bbf4>] (dvb_unregister_frontend [dvb_core]) from [<7f17e57c>] (dvb_usbv2_exit+0xc8/0x140 [dvb_usb_v2])
[  240.347444] [<7f17e57c>] (dvb_usbv2_exit [dvb_usb_v2]) from [<7f17e648>] (dvb_usbv2_disconnect+0x54/0x78 [dvb_usb_v2])
[  240.347481] [<7f17e648>] (dvb_usbv2_disconnect [dvb_usb_v2]) from [<805378e8>] (usb_unbind_interface+0x84/0x2d0)
[  240.347514] [<805378e8>] (usb_unbind_interface) from [<804a9124>] (__device_release_driver+0xbc/0x150)
[  240.347542] [<804a9124>] (__device_release_driver) from [<804a91e4>] (device_release_driver+0x2c/0x38)
[  240.347569] [<804a91e4>] (device_release_driver) from [<804a8b64>] (bus_remove_device+0x11c/0x148)
[  240.347594] [<804a8b64>] (bus_remove_device) from [<804a4354>] (device_del+0x1e8/0x350)
[  240.347619] [<804a4354>] (device_del) from [<80535d08>] (usb_disable_device+0xf8/0x32c)
[  240.347643] [<80535d08>] (usb_disable_device) from [<805293c4>] (usb_disconnect+0xa4/0x250)
[  240.347666] [<805293c4>] (usb_disconnect) from [<8052b3d4>] (hub_event+0x5c4/0x1664)
[  240.347693] [<8052b3d4>] (hub_event) from [<8004f1c8>] (process_one_work+0x158/0x558)
[  240.347718] [<8004f1c8>] (process_one_work) from [<8004f61c>] (worker_thread+0x54/0x5a0)
[  240.347744] [<8004f61c>] (worker_thread) from [<80057774>] (kthread+0x180/0x198)
[  240.347774] [<80057774>] (kthread) from [<80016fc8>] (ret_from_fork+0x14/0x2c)

Do you have enough power for your USB Stick? Have you connected it to a powered Hub? Otherwise try adding max_usb_current=1 in config.txt

Have you tried it outside of Kodi? Using the TVheadend Webserver to stream the channel does it also crash?

Do you have enough power for your USB Stick? Its a 2A power supply bought from raspberry Pi.

Have you connected it to a powered Hub? no

Otherwise try adding max_usb_current=1 in config.txt will do

Have you tried it outside of Kodi? Using the TVheadend Webserver to stream the channel does it also crash? No its always worked fine when I stream to my laptop through TV head web site. Haven’t tried with this build however.

Ok add the power setting (and reboot). If that is not changing it and/or the access vie webserver from PC also crashes we need to dig further.

That didn’t help, same result. I’ll get a powered hub maybe tomorrow.

Maybe try to downgrade the kernel.
Execute sudo apt-get install --reinstall rbp2-image-4.3.3-3-osmc and reboot afterwards