"Enter files section" help

Just installed OSMC. I downloaded SMB from the app store and added my win7 pc “ISO” directory. All the iso files show up.

The main Kodi screen is telling me my library is empty and I need to populate it. I “Enter files section” and see 2 folders:

slides and slides_vga. Don’t know what they are. How do I add the folder I just set up with SMB? I see nothing else on the screen except “Options” and that shows “View options” and “Actions” (with"Update Library" as a choice). Nowhere do I see an option to add a folder.

Thanks

You only need the SMB Server from the App Store if you want to share files from OSMC with other devices. Not when you want to access files on your WIndows PC from OSMC.

I am a bit confused here, you write “All the iso files show up.” so you can see them on OSMC?

Basically it is Videos -> Files -> Add Videos -> Browse -> Windows network (SMB).

These are noobs files. Looks like you are browsing the SD card. We recommend installing from osmc.tv/download if you plan to use OSMC as the main OS

Sam

http://kodi.wiki/view/Adding_video_sources

Thanks for the reply. I should have specified that I’m running on a Raspberry Pi and playing files off a win7 machine. Videos -> Files -> Add Videos -> Browse -> Windows network (SMB) worked. I’m able to play the files although one of them plays for 10 - 15 seconds, stops, and displays a “frowny face” screen, goes black and pops back to the video menu. The CPU usage is at 100% and playback is a little slow. Not choppy, but not quite right.

I’m running on a Raspberry Pi model B. Just wanted to see how well it worked. I have Pi2 Model B also. Maybe I need to try that one. The CPU is a little faster and is quad core.

Thanks again.

It’s a model B and came with NOOBS on the SD card. I installed OSMC from a menu after bootup. As I mentioned in my reply to fzinken, I’m running from an early model Pi (B). The playback is not quite right. Not choppy, but a little slow. I have a newer Pi2 Model B I’m going to try.

Thanks for replying.

Thanks for the link. Lots of good info there!

Well that might depend on the codec the file is using. Some codecs might require a licence key to play smooth others might not play at all on a Pi.
But generally they should not lead to a crash, that is more likely a power supply issue or some device issue. See this two sections.

It would be good if we could find out more about the file you are having issues playing. Please see the mediainfo section in How to submit a useful support request - General - OSMC

Your power supply probably isn’t up to scratch. You can learn more on our Wiki here: https://osmc.tv/wiki/raspberry-pi/frequently-asked-questions/