Err_empty_response

After the june update, the web access of the kodi (using Chorus 2) is denied. Everything goes fine after a moment later when a message appears.
Capture

It hasn’t happened before, so I think it’s because of the update. The ping is never lost so I don’t know what’s causing it.

The logs here: https://paste.osmc.tv/ucimebequb

Jul 07 23:38:51 raspbmc mediacenter[340]: terminate called after throwing an instance of 'std::bad_alloc'
Jul 07 23:38:51 raspbmc mediacenter[340]:   what():  std::bad_alloc
Jul 07 23:38:51 raspbmc sudo[424]: pam_unix(sudo:session): session closed for user osmc
Jul 07 23:38:51 raspbmc mediacenter[340]: /usr/bin/mediacenter: line 142:   424 Aborted                 sudo -u osmc LIRC_SOCKET_PATH=/var/run/lirc/lircd $KODI --standalone -fs
Jul 07 23:38:51 raspbmc mediacenter[340]: Kodi exited with return code 134 after 0 hours, 32 minutes and 28 seconds
Jul 07 23:38:51 raspbmc kernel: Console: switching to colour frame buffer device 160x45
Jul 07 23:39:02 raspbmc mediacenter[340]: Starting Kodi...

Found 4 occurance of this. Looks like your mediacenter dies after 20-30 mins since it cannot allocate memory. Root cause unknown to me.

Do you have any memory intensive software running on your P3 in addition to kodi?

I see. A new log that after a while when I play music somc keeps loading and nothing comes up

https://paste.osmc.tv/nejawawoho

. So that’s it.

Not that I’m aware of, just installed kodi this it when I do htop. If there’s a better way to know it, thanks

Reinstalled again and still the problem persist, unable to open the web interface. Just by doing nothing it just stops playing. I can still enter osmc via ssh.

Here are the logs: https://paste.osmc.tv/evenuvekeg.

Thanks!

Hi,

Have you tried on a new sd card?

Thanks Tom.

Update: The problem persists :frowning: . Changed the sd card, latest build and still freeze out of nowehere.

Final logs are here: https://paste.osmc.tv/ihuzozuluc

Will try that and let you know.

Thanks

1 Like

Please install a fresh build and don’t make any changes to it. See if that works.

If the base build works, which is what I would expect, then, one step at a time, make a single change and reboot. See if it still works. Repeat until you find what’s causing the problem.

Update: Just did it step by step and ti froze while scanning the tv shows :(. Clean install, the only addon installed was theTVDB one. Here is the full logs: https://paste.osmc.tv/oxuheqedex

Thanks. Will do that and see if see if some addons may be the problem.

I found these lines repeatedly in the Kodi log:

2019-07-14 04:57:40.000 T:366912224 WARNING: Create - unsupported protocol(/usr/share/kodi/addons/webinterface.default/http) in /usr/share/kodi/addons/webinterface.default/http://110.249.212.46/testget
2019-07-14 04:57:40.001 T:366912224   ERROR: Exists - Error checking for /usr/share/kodi/addons/webinterface.default/http://110.249.212.46/testget

IP address 110.249.212.46 seems to be in China. :bomb:

I have no idea what is happening but it looks like your machine is probably infected. What steps did you take before posting the log?

These:

  • Installed OSMC
  • Configured OSMC
  • Set content Movies
  • Changed TV resolution
  • Set content TV Shows
  • Set content MV
  • Set content Music
    I left it scanning the music and went to sleep. The next day, it was frozen an couldn’t enter via web

You don’t happen to have your ssh port open or forwarded to the internet do you?

1 Like

I looked at the router configuration and it was, must’ve forget to disable. It is now deleted.

Reinstall again as it looks like you’ve been hacked. Once you get up and running if you really need remote SSH access, use a port other than 22, change the osmc password to a strong password, or even better if you can turn off password authentication for SSH and only allow access via SSH keys.

That IP address has “form”:

https://www.abuseipdb.com/check/110.249.212.46

1 Like