Error configuring fstab based Samba share mounts

Hi all,

Recently purchased the Vero 4K and have spent several hours trying to properly configure this but keep running into the same issue. Here’s a snapshot of the error message:

osmc@osmc:~$ smbclient -L 192.168.1.110
Enter osmc’s password:
OS=[Windows 10 Home 16299] Server=[Windows 10 Home 6.3]

    Sharename       Type      Comment
    ---------       ----      -------
    ADMIN$          Disk      Remote Admin
    C$              Disk      Default share
    D$              Disk      Default share
    IPC$            IPC       Remote IPC
    Movies          Disk
    print$          Disk      Printer Drivers
    TV Shows        Disk
    Users           Disk

Connection to 192.168.1.110 failed (Error NT_STATUS_RESOURCE_NAME_NOT_FOUND)
NetBIOS over TCP disabled – no workgroup available

And here’s what my fstab file looks like:

rootfs is not mounted in fstab as we do it via initramfs. Uncomment for remount (slower boot)

#/dev/vero-nand/root / ext4 defaults,noatime 0 0
//192.168.1.110/Movies /mnt/Server_Movies cifs x-systemd.automount,noauto,rw,iocharset=utf8,username=,password=,uid=osmc,gid=osmc,file_mode=0770,dir_mode=0770 0 0

I’m quite new to all of this so I apologize if this is a redundant question. Let me know what additional information I can provide to assist in troubleshooting.

Thanks!

Your username and password fields are empty, that wouldn’t work. Either fill them in the fstab or link to a password file

Thanks for the quick reply. I don’t believe that I have any sort of username or password to access my Windows shares as I have “full access” set to everyone. Do you recommend I reconfigure it with a username and a password?

Yes, you need to do that guest account would not work. If you don’t want to use your default user just create a osmc user on your PC

Thanks. So I would need to create an Osmc user on my PC in the same way I have different user accounts for logging into Windows?

Yes, unless you want to use any of the existing accounts. If you create a new osmc user it’s the easiest to control access rights

Strange - I attempted to use one of my existing users “Brian” and I get the same error message.

osmc@osmc:~$ smbclient -L 192.168.1.110 -U Brian
Enter Brian’s password:
Domain=[THOREAU] OS=[Windows 10 Home 16299] Server=[Windows 10 Home 6.3]

    Sharename       Type      Comment
    ---------       ----      -------
    ADMIN$          Disk      Remote Admin
    C$              Disk      Default share
    D$              Disk      Default share
    IPC$            IPC       Remote IPC
    Movies          Disk
    print$          Disk      Printer Drivers
    TV Shows        Disk
    Users           Disk

Connection to 192.168.1.110 failed (Error NT_STATUS_RESOURCE_NAME_NOT_FOUND)
NetBIOS over TCP disabled – no workgroup available
osmc@osmc:~$ sudo nano /etc/fstab
GNU nano 2.2.6 File: /etc/fstab

rootfs is not mounted in fstab as we do it via initramfs. Uncomment for remount (slower boot)

#/dev/vero-nand/root / ext4 defaults,noatime 0 0
//192.168.1.110/Movies /mnt/Server_Movies cifs x-systemd.automount,noauto,rw,iocharset=utf8,username=Brian,password=test,uid=osmc,gid=osmc,file_mode=0770,dir_mode=0770 0 0

Well smbclient is not the same as your fstab mount. So is your mount also fialing? What does ls -lah /mnt/Server_Movies gives you?

In regards to the error of smbclient you might want to try to enable NetBIOS over TCP on your windows machine to test if that helps.

I have “Enable NetBIOS over TCP/IP” checked in my Advanced TCP/IP Settings but it doesn’t seem to change the error message about it being disabled.

After the command you recommended, here’s the screen that came up:

osmc@osmc:~$ ls -lah /mnt/Server_Movies
total 4.0K
drwxrwx— 2 osmc osmc 0 Oct 31 17:24 .
drwxr-xr-x 3 root root 4.0K Dec 19 12:58 …
drwxrwx— 2 osmc osmc 0 Dec 12 16:34 Seen
drwxrwx— 2 osmc osmc 0 Oct 31 19:17 Unseen
osmc@osmc:~$

So looks like your fstab mount is working. I assume “Seen” and “Unseen” are folders on your PC

Yep, those are the two sub folders within my Movies folder. Based on this, does it seem to be working properly even though the smbclient command returns an error?

Yes, as mentioned fstab mount and smbclient two different topics. Just now in Kodi add the sources via root filesystem -> mnt -> Server_Videos and you are done

Good news - it seems to be working now. Thanks for all the help!