Error downloading updates

Just got my vero 4k+, went to manually scan for updates, right when the pop up says Starting Download another popup says Error installing: Please report this on the OSMC forum

Can you try checking again via My OSMC?
Your connection may have dropped during the update

Cheers

Sam

same issue, the error popup then after that it says there are no updates available, but it is on july.

To get a better understanding of the problem you are experiencing we need more information from you. The best way to get this information is for you to upload logs that demonstrate your problem. You can learn more about how to submit a useful support request here.

So, in summary:

  • activate the logging
  • reboot the OSMC device
  • reproduce the issue
  • upload the log set either using the Log Uploader method within the My OSMC menu in the GUI or the ssh method invoking command grab-logs -A
  • publish the provided URL from the log set upload, here

Thanks for your understanding. We hope that we can help you get up and running again shortly.

it doesn’t seem to be connecting to the internet, it has an IP and should be fine on my end, the get more skins option doesn’t work, upload the logs from my OSMC doesn’t work,

osmc@osmc:~$ grab-logs -A
grep: /var/log/apt/term.log: No such file or directory
grep: /var/log/apt/history.log: No such file or directory
Exception Details:

Traceback (most recent call last):
File “/usr/bin/grab-logs”, line 816, in dispatch_logs
raise ValueError(‘Upload Returned Empty String’)
ValueError: Upload Returned Empty String

Failed to upload log files, copying to /boot instead. (Unable to verify)

Well than let’s start some checks:

Post output of:

ip addr
ip ro

osmc@osmc:~$ ip addr
1: lo: <LOOPBACK,UP,LOWER_UP> mtu 4096 qdisc noqueue state UNKNOWN group default
link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
inet 127.0.0.1/8 scope host lo
valid_lft forever preferred_lft forever
inet6 ::1/128 scope host
valid_lft forever preferred_lft forever
2: eth0: <BROADCAST,MULTICAST,DYNAMIC,UP,LOWER_UP> mtu 1500 qdisc pfifo_fast state UP group default qlen 1000
link/ether c4:4e:ac:29:33:97 brd ff:ff:ff:ff:ff:ff
inet 192.168.88.5/24 brd 192.168.88.255 scope global eth0
valid_lft forever preferred_lft forever
3: wlan0: <BROADCAST,MULTICAST> mtu 1500 qdisc noop state DOWN group default qlen 1000
link/ether 10:d0:7a:ac:39:1a brd ff:ff:ff:ff:ff:ff
osmc@osmc:~$ ip ro
default via 192.168.88.1 dev eth0
192.168.88.0/24 dev eth0 proto kernel scope link src 192.168.88.5
192.168.88.1 dev eth0 scope link

Ok next tests:

cat /etc/resolv.conf
ping 192.168.88.1
ping 8.8.8.8
ping google.com

Output of route would also be good.

osmc@osmc:~$ cat /etc/resolv.conf

Generated by Connection Manager

nameserver 192.168.88.1
nameserver 75.75.75.75
nameserver 75.75.76.76
osmc@osmc:~$ ping 192.168.88.1
PING 192.168.88.1 (192.168.88.1): 56 data bytes
^C
— 192.168.88.1 ping statistics —
7 packets transmitted, 0 packets received, 100% packet loss
osmc@osmc:~$ ping 8.8.8.8
PING 8.8.8.8 (8.8.8.8): 56 data bytes
^C
— 8.8.8.8 ping statistics —
8 packets transmitted, 0 packets received, 100% packet loss
osmc@osmc:~$ ping google.com
ping: bad address ‘google.com

It is currently playing video through the nfs through the gui on my local network.

If you can SSH to the device, can you ping the device you SSH’d in from?

yes.

osmc@osmc:~$ ping debmain
PING debmain (192.168.88.101): 56 data bytes
64 bytes from 192.168.88.101: seq=0 ttl=64 time=7.325 ms
64 bytes from 192.168.88.101: seq=1 ttl=64 time=0.723 ms
64 bytes from 192.168.88.101: seq=2 ttl=64 time=0.912 ms
64 bytes from 192.168.88.101: seq=3 ttl=64 time=0.716 ms

Ok, so which IPs work and which don’t?

What’s IP of NAS and device you’re using to SSH in?

Sam

locals seem to be working, externals are not.

I’m SSHing in from a different VM, not my NAS. but my NAS is set up to approve the IP, I went from 4k to 4k+, I just changed the MAC address
NAS: 192.158.88.9
debmain: 192.168.88.101

also I can’t scan the TV or Movie databases because of this.

Can you explain what you mean? I assume you mean you changed the MAC Address in your DHCP server?

Have you disconnected the Vero 4k?

On your “VM” can you show output of route and arp -a?
Also please arp -a from the Vero 4k+.

yes you assumed correctly, my NAS only lets in that IP so I set the new one for that, and it’s working through the GUI

route and arp aren’t commands debian can find but here is osmc:

osmc@osmc:~$ arp -a
? (192.168.88.6) at 50:7b:9d:4f:3e:ef [ether] on eth0
mikrotik (192.168.88.1) at 64:d1:54:cb:af:8d [ether] on eth0
debmain (192.168.88.101) at 12:a4:51:1e:77:85 [ether] on eth0
synology (192.168.88.9) at 00:11:32:60:3e:81 [ether] on eth0

You mean your VM is debian OS but you have not arp installed?

Did you disconnect the old Vero?
Does it work when you disable wired and enable wireless (at that moment NAS access might not work but Internet may)
Did you try to reboot your Mikrotik router?