Error install updates - unknown package

HI all

I’m having issue updating osmc.

tried sudo apt-get dist-upgrade

this is what I get

osmc@hitzOSMC:~$ sudo apt-get dist-upgrade
Reading package lists… Done
Building dependency tree
Reading state information… Done
Calculating upgrade… The following packages were automatically installed and a re no longer required:
_ apt-transport-https armv7-libafpclient-osmc libbluray1 libcurl3-gnutls_
_ libflac8 libgssapi3-heimdal libheimntlm0-heimdal libkdc2-heimdal libx11-6_
_ libx11-data libxau6 libxcb1 libxdmcp6 rbp2-image-4.4.16-1-osmc_
_ rbp2-image-4.4.16-4-osmc_
Use ‘apt-get autoremove’ to remove them.
The following NEW packages will be installed:
_ rbp2-image-4.4.16-6-osmc_
The following packages will be upgraded:
_ armv7-splash-osmc base-files base-files-osmc bind9-host e2fslibs e2fsprogs_
_ gnupg gpgv libbind9-90 libc-bin libc6 libcomerr2 libdns100 libgudev-1.0-0_
_ libidn11 libisc95 libisccc90 libisccfg90 liblwres90 libmysqlclient18_
_ libpam-systemd libpolkit-agent-1-0 libpolkit-backend-1-0_
_ libpolkit-gobject-1-0 libpython2.7 libpython2.7-minimal libpython2.7-stdlib_
_ libsqlite3-0 libss2 libssl1.0.0 libsystemd0 libudev1 libxml2 locales_
_ multiarch-support mysql-common openssl policykit-1 python2.7_
_ python2.7-minimal rbp-bootloader-osmc rbp-userland-osmc rbp2-kernel-osmc_
_ systemd systemd-sysv udev wget wpasupplicant_
48 upgraded, 1 newly installed, 0 to remove and 0 not upgraded.
Need to get 0 B/49.4 MB of archives.
After this operation, 66.3 MB of additional disk space will be used.
Do you want to continue? [Y/n] y
Extracting templates from packages: 100%
Preconfiguring packages …
dpkg: unrecoverable fatal error, aborting:
_ files list file for package ‘libmicrohttpd10’ is missing final newline_
E: Sub-process /usr/bin/dpkg returned an error code (2)

not sure what to do.


Thats a Kodi log only would not help, upload full logs with grab-logs -A


Thats all logs


Thats grab-logs

Your system has some filesystem corruption

Try clean the archives (apt-get clean), and get a better SD card and PSU

Using the command above i get error saying could not open lock file.

Using sudo before i get no confirmation if anything is done.

Ran update after i still get the same message.

It means that the pre/post/control files on the system itself are corrupted. You will need to reinstall and check your SD card and PSU