Error installing update error

I haven’t used the Vero4k for a few days but today I saw an error message saying an update had failed. I then tried to do it manually in MyOSMC but it stuck on 0% for 10 minutes then gave me the same message and to come here. Another pop up then told me there was no update available (as if the update had worked). Just tried it all again with the same result. None of my add-ons seem to work but I can play content from my external HDD.

I’ve had a look here to see if there is a way of forcing it via SSH but it’s not that clear. I’ve seen these commands but I’m not really sure which to use…

sudo apt-get update
sudo apt-get upgrade

Any advice greatly appreciated, thanks.

This command should never be used on OSMC (actually it is now redirected anyhow).

You could execute
sudo apt-get update
sudo apt-get dist-upgrade

And if that fail upload logs via grab-logs -A
BTW if you haven’t updated since November this is a “big” update and can take upto 40 minutes.

SSH didn’t work either so I rebooted and it all now seems to be updating. Thanks for the reply :+1: