Error Installing Updatres

For the last few weeks whenever I ran the OSMC Update utility I would get the error message “OSMC Update”. And that I should report this on the forum. So here I am.

Today I performed the distribution upgrade by ssh-ing from my computer. After the installation finished, I turned on my TV to see what, if anything, I was supposed to do. Reboot perhaps? The screen had a few lines on it and it sat there for a half hour or so doing nothing. Finally, I issued a reboot from the computer’s terminal and Isengard booted, I guess. I couldn’t find anything that told me it is Kodi 15 or Isengard I am running under but it did say that the system had been updated today. I assumed everything went as planned. So I ran Updates in the OSMC utility but still got the error message.

I checked the log file and found a bunch of errors. I have no idea what to do about them. I tried to upload it and discovered I can only upload images. So I figured I’d past it below. No dice. Too many characters. I give up.

Hopefully someone will have a suggestion.

Provide logs with the log uploader within MyOSMC.

Oh! I just edited my post and didn’t see your message. Okay, I’ll see if I can find it.

Okay. It took me a while and Google to find out where I could find MyOSMC which is called “OSMC Settings” in my Pi. I’ve uploaded the Kodi.log. Hope you will find it okay. It has a whole bunch of errors in it. Is this enough or do you want more logs?

You must provide the URL that is returned when you use the log uploader…

Yes, of course. Everyone is expected to be all knowing, if not, just a little info at a time will be provided. The URL is I don’t know why I jotted it down. Please, is there anything else you need from me?

Yes, you need to select “All Logs” in the log uploader, re-submit, and provide the new URL. This log does not contain all the info we need, particularly the apt logs…

For problems with updating we also need the APT logs - you’ve only provided Kodi logs. Also it doesn’t appear that the Kodi log was taken when the problem occured, so please try running updates again to reproduce the error message that you see, then go into the log uploader again (without rebooting) and make sure you also choose APT logs as well as Kodi logs. (All logs are preferable as it’s hard to know for sure what other clues might be needed, but at minimum Kodi and APT logs)

I ran the updater once again. This time I didn’t get an update failure message. There were 11 updates - #9 finished and #10 flashed by so fast I couldn’t read what it was. I never saw what happened with #11. Then I got the OSMC Updater message that there are no updates. Does that mean there are no updates left and they’ve all been installed? Or is that another glitch.

I uploaded all the logs this time and the URL is Something is definitely wrong because my system is doing some funny things like popping up a slideshow settings window when I’m trying to select a video. This happened with several different videos. I’ve also noticed some videos play only audio, no video. Others no audio, only video. And some don’t play at all. I’ve also been having a devil of a time trying to play stuff on 1Channel (Primewire). I know these are different problems that what I posted here but, perhaps my system is totally screwed up.

I appreciate you going over my logs. Perhaps you can tell me what must be done. Thanks for your help.

I did another update tonight and that seems to be working okay now. I guess it’s the old situation about feeling ill and going to see the doctor but when you get there you’re suddenly feeling better.

I would like to know, though, if there’s anything in the logs that might be fixed.