Error processing archive diskmount-osmc_1.4.0_all.deb


I have a problem trying to update my osmc on a pi2, the error that I received is:

Error installing: diskmount-osmc (1.4.0)
Please report this on the OSMC forum.

Then if I try to see what happens via terminal I can see this other error when the file is processing:

(Reading database … 26367 files and directories currently installed.)
Preparing to unpack diskmount-osmc_1.4.0_all.deb …
Unpacking diskmount-osmc (1.4.0) over (1.3.8) …
dpkg: error processing archive diskmount-osmc_1.4.0_all.deb (–install):
unable to remove obsolete info file `/var/lib/dpkg/info/diskmount-osmc.md5sums’: Input/output error

I tried to look for the file diskmount-osmc.md5sums but doesn´t exist so right now I´m running out ideas.

Any help/ideas/suggestions?



You have probably had some unsafe shutdowns and need to run fsck on the partitions to fix them.

Thanks Shadow,

I´m trying to run the fsck but I can´t find the way to check the root partition, I disconnected the hard drivers plugged in the pi and the error still there so my guess is something wrong with the sd partitions but I can´t find a way to check it.

Any suggestion?

enter the recovery console by holding down ‘shift’ on bootup
then you can run fsck


Tmacca thanks for the reply but I can´t access to the recovery console I tried to press the key from the blank screen with no result also I tried start pressing as soon the osmc boot screen appears with no result as well also I tried pressing the key in different time on boot but is not entering in the recovery console. Thoughts?


Shift for Recovery console is broken at the moment unfortunately.

The easiest way to force an fsck and repair at the moment is to edit /boot/cmdline.txt and add a space then the following two options at the end of the line: (one long line) fsck.mode=force

This should force fsck and automatic repair on next boot. When the problem is fixed you can remove them. (Or only remove fsck.mode=force, then it will only run fsck if corruption is detected)

For this to work you will also need to edit /etc/fstab and change the last 0 to a 1 for both lines.