Error updating - RPi2

Hi everybody,

While updating, I’m getting this error:

0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
2 not fully installed or removed.
After this operation, 0 B of additional disk space will be used.
Do you want to continue? [Y/n] y
Setting up rbp2-image-4.4.27-2-osmc (2) …
Internal Error: Could not find image (/boot/vmlinuz-4.4.27-2-osmc)
dpkg: error processing package rbp2-image-4.4.27-2-osmc (–configure):
subprocess installed post-installation script returned error exit status 2
dpkg: dependency problems prevent configuration of rbp2-kernel-osmc:
rbp2-kernel-osmc depends on rbp2-image-4.4.27-2-osmc; however:
Package rbp2-image-4.4.27-2-osmc is not configured yet.

dpkg: error processing package rbp2-kernel-osmc (–configure):
dependency problems - leaving unconfigured
Errors were encountered while processing:

any idea?


To get a better understanding of the problem you are experiencing we need more information, including logs from you. Our wiki contains detailed steps for providing the relevant info we need to help you.

We need to see what commands the user ran to get to this stage. You have only posted part of your console output

Unless you know what you’re doing, you should probably update via the official method in My OSMC.

grab-logs -a will result in a pastebin link that you can post here so that we can see what has happened.

Hi! Thanks for the answer. I think I updated with the official method though. I remember getting an error and then trying the apt-get update and upgrade from the CLI. Anyway, I will post the logs here.

Thanks again.

Hi again,

Here are the logs:

Thanks in advance. I’m still getting that error while upgrading.

You have run apt-get upgrade. Several times. This is dangerous and ultimately fatal.

You will need to reinstall, there is nothing else you can do.

There is also evidence of SD card corruption, you may need to reformat before re-installing or replace your card.

Ok, I solved the problem without something as dramatic as reinstalling everything…

I edited /var/lib/dpkg/status and search for the rbp2-image-4.4.27-2-osmc file. I deleted all the lines about this package (the whole section I mean). Save, quit and sudo apt-get dist-upgrade again. Now it tried to install the newest rbp2-kernel-osmc but it couldn’t because of the dependency. I did a sudo apt-get install -f and it installed the rbp2-image and the kernel-osmc update.

I tried to restart after that and everything seems to be ok. No warnings whatsoever and I don’t have any update to install. Thanks for the tip anyway. I was trying to avoid reinstalling, which in my case would be a total pain in the ass.

That will work for now, but you’ll have problems with the November update.

1 Like

Crossing fingers then :slight_smile: I’ll cross that bridge once I’m there. Let’s see what other problems I’ll be facing.

When you post your problem after the next update, please ensure to link this thread so that we know the root caise of your problems straight away. We are volunteers and reissuing the same advice after reading the same errors in log files is not really an efficient use of time.

Please plan to reinstall before the next update, it will save everyone a lot of effort.

If something, I think I have been really thankful in this thread. I appreciate the effort of everybody reading logs, answering me and trying to find a solution. I probably messed something in my system (didn’t know the fatal effects of the apt-get upgrade command here), and I am aware of the effort that I may have caused because of this. I’m sorry for that.

However, I sense a bit of hostility in your messages. I think it is not necessary.

If I have problems with the next update (and the condition ‘if’ is the most important thing in the sentence), I’ll try to fix it myself first, like I usually do, and I’ll post here all the details, including this thread, just in case it’s related.

Again, thank you all for your effort, time and knowledge. You have been really useful to me in the past too.


Don’t sense hostility in his posts, just that he asks to know the full story. We’ve seen it before where someone says that their update failed, but they’ve done all sorts of things, like install Mono, run rpi-update despite a warning not to do so, etc.

No hostility, just trying to save you a lot of effort. From experience it is much less arduous to plan a new install and carry it out in a controlled fashion than it is to desperately try and recover lost information from a system which is no longer functioning. I’ve been there!

You’ve got lucky this time, it was recoverable. Next time it may not be. I don’t like leaving people with a ticking timebomb if I can tell them how to prevent it, that’s all.

Happy viewing.

Thank you both. About Mono, I don’t like it either, but I needed that :slight_smile: About the apt-get upgrade, I have learned a valuable lesson from it. The problem with that is that I use it everyday in my Ubuntu machines without any problems. Since OSMC is based on Debian, I never supposed that apt-get upgrade could be a source of severe problems.

About reinstalling…well, I know that sometimes it’s just the best solution. However, considering my current installation (couchpotato, sonarr, transmission, etc), it would be my last choice, after trying everything else. I also posted what fixed my error in case it can solve the situation for others too. I’m not saying is the best solution, but at least you get rid off all the errors during any apt-get operation and the system becomes updated again.

Anyhow, thank you Sam and Gavin. You have given me some wise advices that I’ll take into account.


The use of apt-get upgrade hasn’t been recommended on Ubuntu or Debian since 2009. You may just be getting away with it as packages are updated less often and dependencies change less often.

Note taken then! Thanks for the tips.

Well, I’m back again. Finally, my SD card got corrupted and unbootable. I just reinstalled everything from scratch with the OSMC installer and, after some backup recoveries, everything’s the way it was before. Now I don’t get random crashes/reboots anymore, it’s perfectly stable.

So, even though I solved the apt problems, you were right about the SD card. A fresh installation and setup was not the nightmare I thought it would be.

Thanks everyone.

1 Like

I hope you installed to a new SD card

No, I did not. I think the SD card is not the problem itself. Let’s see how it goes. I did a complete format and a fresh install.

Before that, I made a dd copy of the sdcard. I formatted the sdcard, install a new OSMC and was working well. I restored the dd that I did before and it couldn’t boot again. So, maybe iit wasn’t the sdcard itself but the operating system.

Anyway, I’ll keep an eye on the SD card and make regular backups, just in case. Thanks.