Failed to apt-get update

Hello

I am getting this here:
W: Failed to fetch http://apt.osmc.tv/dists/jessie/main/binary-armhf/Packages Hash Sum mismatch

E: Some index files failed to download. They have been ignored, or old ones used instead.

Run sudo apt-get update again?

Sam

Tried already, also deleted /var/lib/apt/lists, same result.

Just wait a little while, some of the mirrors are updating.

The Packages file needs a random taint to filesize to flag changes to the mirror system. I have been working with @Karnage on this, and we’ll have something that works better soon. For now, just wait a little bit for the mirrors to sync and the issue will disappear of its own accord.

We should have this resolved on the APT signing server soon and then this won’t be a problem in the future.

Sam

cool, thanks

mind trying something for me
sudo rm -r /var/lib/apt/lists/*
nano /etc/apt/apt.conf.d/99fixbadproxy

add this to it

Acquire::http::Pipeline-Depth 0;
Acquire::http::No-Cache true;
Acquire::BrokenProxy    true;

then

sudo apt-get update && sudo apt-get dist-upgrade

I do not recommend following the above instructions, and it won’t solve the issue

The mirror should be synchronised now anyway.

Sam

All good now.

All,

I just tried doing apt-get update twice today, no luck. Still same messages as topic heading for W: and E: drives.

Any ideas?

Mark

Wait a few moments and try again.

We are aware of a mirror issue which can result in this message being displayed if a repository is recently refreshed. The issue will go away after a couple of minutes and won’t be detrimental to your system (you can just re-run update)

Thanks Sam. It’s probably been an hour or so since my initial post - and apt-get update worked with no errors.