"failed to start load kernel modules"

#1

this messages appears if i boot osmc. as suggested in various linux boards i did the following:

osmc@agbenno:~$ systemctl status systemd-modules-load.service
● systemd-modules-load.service - Load Kernel Modules
   Loaded: loaded (/lib/systemd/system/systemd-modules-load.service; static)
   Active: failed (Result: exit-code) since Sam 2015-04-18 13:45:46 CEST; 1min 15s ago
     Docs: man:systemd-modules-load.service(8)
           man:modules-load.d(5)
  Process: 88 ExecStart=/lib/systemd/systemd-modules-load (code=exited, status=1/FAILURE)
 Main PID: 88 (code=exited, status=1/FAILURE)
osmc@agbenno:~$ journalctl _PID=88
No journal files were found.

So the system does not know what process caused the failure?

with kind regards.

benno

#2

What customizations have you done to the system before this issue appeared?

#3

the message appears since the newest update.

#4
#5

mainly 2 customizations:

  • installed cups + print drivers
  • installed couchpotato with git
#6

Do you still have network/ internet access? Maybe there’s a dependency issue, you could try to fix that via sudo apt-get update && sudo apt-get dist-upgrade && sudo apt-get install -f

#7

sure i have network access and did already clean apt-get and remove all broken dependencies (did not resolve the problem). generally everything works as expected, its just that this message makes me a little insecure. i think it might come from some package i installed that was not fully removed on uninstall. my guess is that the kernel module that was needed for this package was removed but the entry to load that module was not removed from startup. is there any chance to track that down (i am no linux expert)?

#8

Please use the log uploader to upload your logs, without those we can only speculate.

#9

ok, so i uploaded the logs: http://paste.osmc.io/SIJOWUJARO

#10

Hi,

Did you check the URL you provided is working ? It doesn’t seem to work for me. Usually the paste.osmc.io URL’s are in lower case and have a dot in them as well.

#11

yes you are right. the correct link is: http://paste.osmc.io/sijowujaro

(my skin showed the link in capital letters.)

#12

Sorry to be a pain, but the system journal is the log of most interest for this problem and you have not included that in the logs you uploaded. (Either choose upload all or make sure system journal is selected)

#13

for nothing! :slight_smile: If anyone is a pain in this thread it must be me for being a complete noob at all this ^^

here the full log: http://paste.osmc.io/tulonoliri

#14

Ok I can see this in your journal log:

Jan 01 01:00:03 B2RASP2 systemd-journal[92]: Journal started
Jan 01 01:00:03 B2RASP2 systemd-modules-load[88]: Failed to find module 'lp'
Jan 01 01:00:03 B2RASP2 systemd-modules-load[88]: Failed to find module 'ppdev'
Jan 01 01:00:03 B2RASP2 systemd-modules-load[88]: Failed to find module 'parport_pc'
Jan 01 01:00:03 B2RASP2 systemd-modules-load[88]: Inserted module 'fuse'
Jan 01 01:00:03 B2RASP2 systemd[1]: systemd-modules-load.service: main process exited, code=exited, status=1/FAILURE
Jan 01 01:00:03 B2RASP2 systemd[1]: Failed to start Load Kernel Modules.
Jan 01 01:00:03 B2RASP2 systemd[1]: Unit systemd-modules-load.service entered failed state.

So it appears it is failing to load those three kernel modules - lp, ppdev, parport_pc. I can’t find those on my install so I assume some package you installed added them and has not removed them properly…

I don’t know much about how systemd-modules-load works (we don’t use it by default in OSMC) but the following page may help:

http://www.freedesktop.org/software/systemd/man/modules-load.d.html

Check the first and third directory shown there (the 2nd doesn’t exist in OSMC) for any conf files that are referencing the above three module names and remove them - it looks like the modules themselves ( .ko files) have been removed but the conf file entry saying to load the modules is still there, hence the failure to load the modules.

If this fixes your problem the most likely cause is a badly written package whose uninstall script doesn’t remove everything it should.

#15

thanks a lot: turned out that it has something to do with cups.

i commented out the modules that are not found. i guess the message will be gone.

osmc@B2RASP2:/usr/lib/modules-load.d$ sudo vi /etc/modules-load.d/cups-filters.conf

/# Parallel printer driver modules loading for cups
/# LOAD_LP_MODULE was ‘yes’ in /etc/default/cups
/#lp
/#ppdev
/#parport_pc

many many thanks for the help!

#16

Ah of course - those drivers are related to PC style parallel ports (LPT1 etc) which the Pi does not have. In fact I’m not sure if any arm based devices have PC style Centronics Parallel ports so it’s possibly a bug in the cups package that it tries to install these drivers on an arm device…

#17

hi, i know it is an old topic, but i got them same problem now, but in the cups-filters.conf there is nothing in it, where do i disable the ports?

#18

Cups isn’t installed by default, so the cups-filters.conf file doesn’t exist unless you’ve installed cups.

Please start a new thread and provide us with details of your problem together with the output from grab-logs -A.

#19

i have installed cups

#20

This is a 2-year-old thread. Still better to start a new thread. IMO. If you then wish to refer back to this thread, please do so.

But… you need to provide us with full details of your problem and the URL from grab-logs -A.