Failing to boot NFS installation

I have Synology DS213j NAS (w latest DSM 5.1-5021) and Pi Model B. Although I’m successful with the NFS installation of OSMC, I’m failing to boot.

The installation is fine, I can also see the installed files on NAS. But after installation when the Pi is rebooting it failes. I keep pinging the Pi and it works until everything stops

Last 4 lines I see are:
Ok Started Wait for Plymouth Boot Screen to Quit
Terminate Plymouth Boot Screen
smsc95xx 1-1.1:1.0 eth0: hardware isn’t capable of remote wakeup
nfs server [IP] not responding, still trying

When nfs server not responding comes up I can’t ping the Pi anymore. Network lost.
I’ve checked cables, changes router, Pi ac adapter. No success.

Any ideas?

This early in the game, I’m not sure NFS install support has been fully fleshed out just yet.

Scratch my previous… It should work… Can you post your cmdline.txt from the fat32 partition on the SDcard?

And also the preseed file please.

We may have found the problem here… Add “,tcp” at the end of your nfsroot= line in cmdline.txt

Here’s mine as an example:

root=/dev/nfs nfsroot=,tcp ip=dhcp rootwait quiet

Thanks for taking the time. Already tried tcp, no change.
I tried your cmdline but again no change. From readin other threads I’ve tried:

  • changing eth0 mtu = 1000 on nas
  • adding tcp in cmdline
  • static ip instead of dhcp
  • tried adding smsc95xx.turbo_mode=N in cmdline.txt
  • re-installing several times

I am also having issues booting from NFS. However, I can’t even get it to install to NFS.
Despite entering an NFS address to install to, it seems to skip that process and install to SD card. Or I think it is anyway, the folder I pointed it to is empty.
I’m wondering if the format of the address I entered is wrong?

nfs://#.#.#.#/Path/To/Folder ??

When prompted by the installer, simply give #.#.#.#:/path/to/folder

The colon (:slight_smile: between the ip and folder is important as well.

Thank you!
I will try that.

I guess it should be expected that folks have slight differences in their networking/filesharing environments that will prove to be a challenge to overcome. Could be some of the flags in your exports or any number of other configurations. Maybe also trying v3 flag either in addition to or instead of tcp flag?

I’ll try to explain my setup a bit, maybe we can narrow something down between us. I’m using gigE switches, server nic is also gigE and set at 7k MTU. I’ll include my relevant export line as well:


Maybe this helps us get somewhere… Does /var/syslog on the server indicate an authenticated mount request from the pi ip when it attempts to boot?

Tried v3 flag, tried vers=3. Tried your export line, think I’ve treid all variants of exports lines. Makes no difference. Bit I can see that it starts reading from the NFS share so I think it’s fine.

What confuses me is that the Pi is losing network connection. smsc95xx is related to networking and that’s the last line I see before the Pi stops responding to pings.

I’m lost.

What does it mean “NFS installation”? I’ve a Synology, too, and a RasperryPi, but I flashed a SD Card, in order to have OSMC on my RPI (and it doesn’t work, anyway…, failing to add NFS shares that are in my DS413j)…

tpx, that’s different. Check 7.2.1 at:

Ah, ok. This similar to the settings I use in order to share my folders with openELEC. Unfortunately, with the same IP, my RasPI/OSMC/Kodi doesn’t connect to the same folders.

Are you working on a failed NFS boot or are you trying to connect to your media shares??

If only the shares, please create a new topic because this has nothing to do with connecting to NFS media shares…

fyi. It’s working now with Alpha 2. Pi network doesn’t disconnect anymore.