Fatal error could not find the root filesystem

I have been running into a problem, that you maybe can help me with.
Trying to reinstall my vero 4k without any luck.

I have tried this file OSMC_TGT_vero3_20180609.img and i have put it on a micro sd card and renamed it to recovery.img. I have also tried a usb device.
I tried to boot up with a toothpick, and the msg i got on the tv was

Waiting for rootfilesystem device/dev/vero-nand/root
Fatal error could not find root filesystem device/dev-vero-nand/root.
If this is a usb install please check the usb device connected.

Now when i try to boot the vero as normal i still get the same msg.
Any suggestions on what could be wrong?

How did you do that? It’s best to use the official installer.

What installer should i use? you got Linux, windows and apple to to choose from.

I just downloaded the image file from here, and puted on a micro sd card

Do i have to mount the image file before puting it on a sd card?

Use the installer that matches the system you use to image your sdcard.

You cannot simply copy the image to the sdcard. You need to use the installer to write the image to the card. These are different processes.

Ah thnx ActionA that explain things im doing the steps right now. I will report back in a sec.

1 Like

ActionA you just saved my day, It works like a charm now thumbs up, Have a great weekend.