February 2018 update issue

Been using RPis for a few years now and pretty much runs rock solid. January release seemed to screw up micro sd card so I created a fresh one and restored a backup to get my old settings.
February release is very quick to boot up but I have lost my context menu, press button on the remote and nothing happens. I seem to remember I had to manually add some files to get the context menu when I first started on the RPi. Was working ok with the January update on the old and replacement sd micro cards. Something in the Feb update has broken it.
Read posts on here and elsewhere it says there should be a file called keymap.xml in the usr directory, but the directory is empty.
Tried different “remotes” from the OSMC/remote program, all work the basic commands, play, pause, exit etc. Just nothing happens when pressing a context menu button.

I would post which TV and which remote control you are using.

On Samsung TV’s for example the button “return” brings up the context menu.
See this post for location ok keymap file:

I use the original XBOX dongle modded and connected to the usb ports, been working for a couple of years, still works in the sense normal commands work, play, pause, FFWD etc.

Remote is a Logitech Harmony remote but it simulates a original XBOX remote. XBOX remote is selected in OSMC, whatever I select say Apple remote etc, it still works the basic commands.

Hi, I had similar issues on my Raspberry Pi 3. The OSMC January update destroyed my SD card as well. I reinstalled a new SD card with the February 2018 update and put back the same private build I made. Now I got other problems: delays, reboots, short freezes, sudden short sound noises. I have installed the latest libreelec now with the same build and all these problems were gone.

Sorry, but the update did not destroy your card. Most likely the card was wearing out and the extra writes from the update pushed it over the edge. It would have failed soon, even without the update.

Without logs, and information about your ‘private’ build, it’s impossible to help you. Are you here looking for help, or just to complain?

Indeed. I’m not sure why someone would take the time to join a forum to say that their SD card was broken by an update; but then provide no further information.

SD cards have a limited lifespan and after an intense write operation such as an update, they’re more prone to fail at that point in time.

As the user hasn’t posted any logs, there’s nothing we can do to help them.

You’re right, the SD card may have been on its end as well but after replacing it by a new one and used the February update I had still problems I haven’t had in the years before. Of course there can be hundreds of other causes as well. I was not looking for help but I noticed this message on the forum and just wanted to say I had similar problems as well with the January update. Sorry for any inconvenience.

Fair enough.

If you want us to help resolve your problem with OSMC, then I’d recommend starting a new thread so we can give your issue the attention it deserves. This also gives OP a chance to have their remote issue investigated and solved.

I believe that the issue with stuttering is caused by a recent firmware update. LibreELEC uses quite old firmware currently. It’s possible that when they update this, you’ll see problems with LE as well. We expect to pinpoint and resolve the problem promptly.


I was the op, the fix in the March 2018 release for the XBOX dongle worked for me, back to normal for now.