Few issues after the April update


My IR remote seems to have stopped working after the April update.
I can see I’m firing IR into the receiver.

I seem to be getting a loud crack when changing source.
My amp is a Denon 7200xa

This all seemed to start happening after the April updates which ironically, I understood should have fix these issues.


Could it be that you are on the development branch?
Please provide full logs with grab-logs -A

osmc@mediasvr:/etc/apt$ grab-logs -A
Logs successfully uploaded.
Logs available at https://paste.osmc.tv/pimujuqare

Houston we have a problem

====================== APT sources.list =================== ZZz2wrJ1 ---------------------- APT sources.list END --------------- ZZz2wrJ1

Can you check your /etc/apt/sources.list

I did have something in there a few weeks ago, but it’s now empty.
I thought I would pickup the standard updates as normal and would overwrite any dev branches ?

Hi @tosh123,

indeed this looks like your on the development branch instead the normal stable one. This also would explain why your IR is not working anymore since the current kernel in the development track does not load the meson_ir kernel module.

Anyway, first the /etc/apt/sources.list(stable):

deb http://ftp.debian.org/debian stretch main contrib non-free
deb http://ftp.debian.org/debian/ stretch-updates main contrib non-free
deb http://security.debian.org/ stretch/updates main contrib non-free
deb http://apt.osmc.tv stretch main

If you want again join the development branch, add line

deb http://apt.osmc.tv stretch-devel main

If IR support is important for you, you can try to downgrade the kernel to #94 version:

apt-get install --reinstall vero364-image-3.14.29-94-osmc

But no guarantee, working with the development branch also means to have a higher risk of being forced to re-install the Vero.

thanks for the info.

I’ve mess up by cleaning up after installing the updates. I think this has stopped me from going back to the old kernel 94.

Is there any other way of loading the old kernel or getting IR support.

It is important as I use control4 which uses IR.

I also still have problems with cracking when changing source, again this only started happening with the April updates.

Thanks again.

No, your were already on kernel #96 and there is no easy rollback to the stable release by all the dependencies already installed, at least as I know.

The only thing I would try is

  • append the stretch-devel line into /etc/apt/sources.list
  • sudo apt-get update
  • apt-get install --reinstall vero364-image-3.14.29-94-osmc
  • remove the stretch-devel line from /etc/apt/sources.list
  • reboot

If this is not working, your system seems already to be borked and it’s time for a re-installation, see OSMC Reinstallation.

Thanks, but I not sure now if that worked, so I have reinstalled my box.

I did still have the cracking sounds after reloading my config, so after enabling and disabling settings I found the problem. It was stereo upmix which was enabled that was creating the issue with the sound.

IR Control works as well!.

All good and happy again,

thanks for the help.

1 Like

Thx for let us know.
Meanwhile we’re able to reproduce issues with active stereo-upmix; the developers will look at this.

If you want stereo upmix, use the PCM device, not HDMI. A fix is coming.