Few Questions

Hi, i got my vero 4k+ device today and tried it out.

Few Questions:
I couldn’t play a HEVC mvk video file. Here the media info of the file:
http://paste.osmc.io/qitolilere.coffee

Is there any media player i can install on my Vero 4k+ to play any video format ?

Basically i want to watch all my movies with vero 4k+ and not stream them.

I have a philipps Tv which i connect to vero 4k+ with HDMI cable and then plugin my wd media external 3 terabyte harddrive with my movies to vero 4k+. Is there any program that i can play any video format on my vero 4k+ ?

And what i also saw is that i can’t see the full subtitles of a video if i play it:

The letters are almost invisible and way below. How i can adjust subtitles more up in the movie or series ?

And is there any other remote controll zapper which i can use which has normal batteries ?

Thanks for help in advance already.

What happened?

Kodi (the MC part of OSMC) includes the video player that can play (any typical) video format.

Nothing just went back to the main screen. No error ect. Nothing.

Is that already built in or do i must install that ?
It has so many settings it is bit confusing as i am very starter with this vero 4k+ box.

Yes.

We’ve provided a simple tutorial on how to provide logs so that we can determine your issue.

To get a better understanding of the problem you are experiencing we need more information from you. The best way to get this information is for you to upload logs that demonstrate your problem. You can learn more about how to submit a useful support request here.

Depending on the used skin you have to set the settings-level to standard or higher, in summary:

  • enable debug logging at settings->system->logging

  • reboot the OSMC device

  • reproduce the issue

  • upload the log set either using the Log Uploader method within the My OSMC menu in the GUI or the ssh method invoking command grab-logs -A

  • publish the provided URL from the log set upload, here

Thanks for your understanding. We hope that we can help you get up and running again shortly.

OSMC skin screenshot:

1 Like

Yes, suggest to check following webpage to understand the basic concept of Kodi.

https://kodi.wiki/view/Adding_video_sources

1 Like

Well seems your TV is overscanning. Check for a aspect setting like 1:1 or just scan.

Well the Vero comes with a IR receiver build in so you could use any IR remote and let the Vero learn the respective codes.

Or you can also use your mobile phone with either the kore or Yatse app

1 Like

Thanks, i could figure out what not worked with the video. I didn’t saw
that i clicked the folder in the folder and not the video itself. My blooper.

Aspect setting is set to 1:1.
I not changed anything but i tried the different modes, strech mode ect, not changes anything with the subtitles. They still just shown way below.

And what do you mean with “just scan” ?

I still can’t figure out how to adjust them more up.
They still seem way to below. I also tried zoom function, wide stretch ect. not helps.
My Display Mode is set to full screen, Resolution: 1920x1080i. Refresh rate: 60.
If i play any video it always goes view mode “custom” which seems normal besides the subtitles way below.

Here is my complet system setting:
https://paste.osmc.tv/isicudimoc

Another Question is how can i set in setting that it always plays any video with the subtitle which is in it ?
I tried on few videos to set it as “default” but as soon i clicked in another video i manually had to click
show subtitle again.

1 Like

Thanks i already have that in settings but that not changes it. Still always have to click the subtitles manually. And still they are way to below.

They are going to be wrong until you get the GUI displaying properly.

Since you’ve been changing lots of setting, I’d suggest starting fresh, so first thing is to make sure that your TV is set to 1:1 for the display option. Once that’s done, ssh into your Vero and run these commands:

sudo systemctl stop mediacenter
mv .kodi/userdata/guisettings.xml guisettings.xml
sudo systemctl start mediacenter

That will reset the Kodi GUI to the default settings. Hopefully the GUI will now be displayed properly.

If the GUI is now displaying properly, test subtitles again.

Where do i find this “Display option” ? And how do i enter these commands in ssh on vero ? I went into the ssh on vero but i don’t see how i can enter any commands.

You type those commands at the $ prompt.

As to the 1:1, Just Scan or whatever your TV calls it, it’s somewhere in your TV menus. We can’t help you with that.

What is that $ prompt ? I went into My OSCM/Services/ and it shows SSH Server running and an empty field. How can i enter the commands in this empty field ? If i click on it it says “Pending Actions Disable: -SSH Server” but i see nothing else to click how i can enter something. Or how do i connnect with this ssh ?

Details regarding how to access the command line interface can be found here on our Wiki: https://osmc.tv/wiki/general/accessing-the-command-line/

1 Like

@Groundhog
What is the exact model of your TV? Do you have a link to the manual?

1 Like

Thanks. I fixxed everything. Went to my normal tv setting and played around till i found how to setup it.

Thanks i fixxed it.

Thanks everyone for his help ! It now works.

For the remote controll i also found a solution and saw in vero that they support my WD media player remote controll so i activated that function and it works perfect. Thanks everyone.

Maybe you share how it’s called on Phillips TV and where to find it.

Just on settings, it had my screen mode somehow in zoom mode. My tv is already older.
Is this one here