File Manager, or "Add Files" <browse> not showing any network options

I have the SMB client configured, but when I try to add a source via File Manager or “Add Files” via any library, I click and all I get is a txt box, not the usual pre-menu of “NFS/SMB/etc”.

I even tried a static url: smb://server/share and got an error.

What’s happened to the old functionality in the GUI?

This is not an instituted change. You have some issue with your system. Provide logs if you’d like it addressed.

Are you running a v18 build by chance? I believe they’re reworking those dialogues

I have the same issue (on an RPI 2, with the last OSMC version).
Also I have this message this morning (not related)

Log ID: inoviwekow

I am not running v18. Running 17.5 Kodi, OSMC October 1. (was there no November update? When I did a manual check, I got a “No Updates” message).

I did see a “failed update” dialog at one point [not the same as the message above though], but I couldn’t tell if it was for an addon or a system update…

Uploaded my logs to ID: uhehajagij

As a workaround, I went into the command-line and mapped a mount point via fstab/cifs

I also got the same message this morning. None of my sources are working and Kodi freezes whenever I try to access one. Please advise.

It seems that there was a new version of Kodi Library Update today.

I’d guess you should raise this on the kodi forum.

Nothing there yet.

I found that my network was having issues and rebooting everything resolved by OSMC freezing issue. Still not good that inability to get my sources never timed out and froze everything.