Files not accessible from other RPi through NFS after latest OSMC upgrade

I have a RPi 4 which i use as a server and a RPi 3 as a client. I’m accessing the files on the client using NFS. I have an external HDD mounted on the server with the files.
I’ve been having this setup and everything was working fine until i updated OSMC on both the devices (I had the march 2022 version before). Now on the client, it cannot open the mounted path from the server. On the server everything is working alright.

Note that I did both the upgrades through the MyOSMC addon, and both finished without any issue.

I tried ls -lah /mnt/ on the client and i’m getting:

ls: cannot access '/mnt/HDD': No such file or directory
total 8.0K
drwxr-xr-x  3 root root 4.0K Oct 26  2021 .
drwxr-xr-x 20 root root 4.0K Sep 19 23:48 ..
d?????????  ? ?    ?       ?            ? HDD

I also tried following the “OSMC as a server” guide here again and everything seemed fine until i ran the exportfs -a command: (note that i’ve ran everything before when i did the setup, more than a year ago)

exportfs: could not open /var/lib/nfs/.etab.lock for locking: errno 13 (Permission denied)
exportfs: could not open /var/lib/nfs/.etab.lock for locking: errno 13 (Permission denied)
exportfs: can't lock /var/lib/nfs/etab for writing

and with sudo:

exportfs: /mnt/HDD does not support NFS export

I restored a backup of the server sd card i made just before updating OSMC, and the files are accessible from the client again.

Can somebody help me what to do next in order to upgrade OSMC on the server?



What filesystem is external drive formatted too? If its fat32/exFat, this link may provide maybe helpful

If it is exFat, may be easier to share via samba.

Regards Tom.

It seem to be exFat.

# df -Th | grep sda1
/dev/sda1      fuseblk   932G  899G   33G  97% /mnt/HDD
# fsck -N /dev/sda1 
fsck from util-linux 2.33.1
[/sbin/fsck.exfat (1) -- /mnt/HDD] fsck.exfat /dev/sda1 

but why does it work now and not after the update? i’ve been using this for more than a year.

now that i have the version before the update, when i try sudo exportfs -a it doesn’t give me any errors.

(i would like to keep the filesystem because, as i’ve read ext4 is not supported by macos, and i use the same hdd on my macbook occasionally.)

Most like because the exfat support went from the fuse driver to the kernel driver.
You could try to use the fuse driver after the upgrade

Can you help me how to do that?

Check out this post


Thank you, it was helpful!

If somebody else has the same issue, here’s what i did after upgrading OSMC again:

  • Unmounted the HDD: sudo umount /mnt/HDD/
  • Mounted it with exfat-fuse: sudo mount -t exfat-fuse /dev/sda1 /mnt/HDD/
  • sudo exportfs -a now finished without issues

At this point the files were accessible from the client but only until a reboot on the server.
Next I updated /etc/fstab - changed the exfat part of the line to exfat-fuse.

Now it seems to be working fine even after a reboot.

Thank you again for the help.

1 Like

exFAT fuse will be much slower

1 Like

Is there a better solution that will let me still share the files as i did before the upgrade without formatting the hdd?

This solution brings you back to how you were before the upgrade, ie with this drive using fuse. If you wanted you could test the performance of this setup and then test a configuration with exFAT using the kernel driver and sharing via samba to see if that is more performative.