First boot up

Hi guys, new here and I’m rather stuck.
When starting up the Raspberry Pi for the first time the screen is red (top left), yellow (top right), blue (bottom left) and cyan (bottom right).

Tried formatting the sd card and starting again but no luck.

Its a Raspberry Pi 2 or 3

Any help would be awesome!

Thanks,
Monk

How are you imaging the SD card and are you ensuring you are using the correct image?

I’m following a tutorial online which says I should extract the downloaded zip file directly onto the SD card. The image comes directly from the raspberry pi website.

Ah ok, you are using the NOOBS install by the sounds of it. What do you have on the SD card, can you give me dome file or folder names or show me a screenshot of the contents.

Our preferred method of install is to use the OSMC installer from here;
https://osmc.tv/download

Thanks for the info, however this is the image that I have downloaded. Still doesn’t work after another format :frowning:

Are you sure it a Pi2 or 3? Post a picture

You shouldn’t extract any zip on the card. Run the installer executable and you will have no problems

I’m having the same issue. Pi 2. I’ve done this dozens of times, but am stuck on rainbow screen. Will try another SD and report back.

Update: After 3rd image download, I tried ‘stuck’ SD card in Pi 3, and it is now installing. Will try to move back to Pi 2 after install.

Update 2: No luck transferring from pi 3 to pi 2. Just a black screen. I’ve tried all 3 build versions that are available for the Pi 2 on the installer, and all 3 get stuck on the rainbow screen. Need a fix for this.

I suspect that what you think is a pi2 may actually be a pi1. This would result in what you are seeing perfectly.

While I can respect that you think that, I’ve dealt with these things for quite some time. I most definitely am working with Pi 2. (4 usb ports, no chip on bottom).

That’s a Pi 1 B+. Pi 2 and 3 have a chip on the bottom.

Post a photo if you suspect otherwise (board up) so we can see the silkscreen

:wink: :osmc:

Ah! I suspect you’re right. I had forgotten about that model.