first install experience (and request for help)

This is my first install of OSMC (on a Rpi3). Unfortunately the first user experience of OSMC was not so great. So I thought I walk you through my experience. Maybe you can help. Maybe you can spot a few ideas for improvements…

The install was quite straight forward. Just the question of OSMC or Kodi was awkward. How would I know? I picked OSMC.

First I added some audio files. Settings > Media > Library > Music… Now I see

29.72 GB Drive
Auto-mounted drives
Add music

OK, so that’s the drive! I can drill down - but I don’t see a way to add that folder!? Confused.
I go back up and try “Add music”. Next “Browse”. But it does not list the drive. Maybe I need to use the mount folder on “Root filesystem”? But why is there “Home folder” then - that’s also on the rootfs. Confused.
Anyway - let’s try. Browsing the rootfs I go for /mnt - but that’s empty. Nothing mounted. But the drive showed up on that other screen. Some searching.
Ah - it’s /media and some weird number. I select the music folder on the drive. But the action just says “OK”.
“OK” what? “OK” to “Browse for new share”? Oh, you have to go inside the folder and then press “OK”. My UX heart bleeds a little. Anyway, I give it a name and now have some music.

Switching to “Music” I don’t see a grid of beautiful album art - no, I see just a menu with “Files” selected as the default. (Why?) I scroll up. “Albums” Hurray - but again just a list. Boy, that’s what I call “lightweight”. At least selecting the album shows the cover art.

Now how do I play the album?
Maybe ? Nope :-/
Now the album art is gone and I get plain list of tracks. (Seriously?)
Ah, I need to select a track then cover art is back. And plays the song! Success!

Awkward that the little progress display constantly switches back and forth between artist and track. As if there was not enough space on that screen. But at least - some music.

Back to the navigation top. I bet there must be some kind of big player screen. And yes - turns out gets me there. Pretty straightford.
Shows the album art and the track information. Nice.

But wait!? Suddenly it’s gone and all I see is some picture of - water???
back to the main screen. OK, let’s try again. Yay!
But then around 10s later again - water. (WTF?)
Is that meant to be some kind of screensaver? Let’s check the settings.

Settings > System > Display? Nope.
Settings > Player > Music > Visualization? Is “none”. Hm.
Settings > Interface > Screensaver! But it’s supposed to “dim” after 3min. No darn water.
I give up. Maybe a new skin can fix this. Let’s try.

Settings > Interface > Skin Hm. Only 2 other available. “Estouchy” and “Estuary”.
Ah - there is: “Get more…”
Better! A list of skins - but no preview???
Well, let’s select “adonic”.

Hah - starts to install for quick moment and… “Installation failed”. OK?
Trying a few more. Same story.
WTF?!

Meanwhile I realized that the music player is only shown for a few seconds on every new track. (Why?) Then it shows the background - the water.

I am not here to complain but… it seems like I need to some help here.
And maybe (just maybe) this also gives some ideas to improve the new user experience? :wink:

Thanks!

Did you read the Wiki or FAQ?

1 Like

Yes,
https://osmc.tv/wiki/general/frequently-asked-questions/
https://osmc.tv/wiki/raspberry-pi/frequently-asked-questions/
Did I miss something?

I think you are confused here. OSMC is a linux distribution optimized to run Kodi on the Pi and Vero hardware.

Kodi works the same no matter what platform you use it on. It’s the same on Windows, Mac, Android, Linux.

So have you looked on the kodi.tv site for guidance on Kodi?

(There can be a little difference, mostly because of the skin you are using in Kodi)

@bmillham that’s the image I installed:

http://download.osmc.tv/installers/diskimages/OSMC_TGT_rbp2_20190105.img.gz

IIUC you are saying it is not the OSMC skin but rather Kodi itself that gave me a hard time? And the skin install error is an issue to be raised with Kodi?

No what I’m saying is that you are using Kodi with the OSMC skin. But most of your questions are standard Kodi questions. Have you used Kodi before? You can always switch to another skin if the OSMC skin doesn’t work for you.

I missed this bit, sounds like you have network problems. Posting logs could help us.

No, I never used Kodi before. Maybe that’s where the confusing starts. I am still not sure what part of the UX is the skin and what part is Kodi itself. It seems like the skin can be very different from the UX (from what I saw online).

Yes, I tried to switch to another skin - but it failed.

You were right - the ethernet cable came loose and I didn’t realize the missing connection. The error message did not mention a missing connection. Sneaky.
Thanks for the pointer!

See Quick start guide - Official Kodi Wiki