Folder with Japanese characters


I’m using OMSC in the Raspberry Pi 3 and I have a folder on my hard drive called ハイ☆スピード!-Free! Starting Days
and in OSMC I can only see Free! Starting Days (ハイ☆スピード! doesn’t appear. Only appears boxes instead of that characters)

How can I fix it? Downloading the Japanese language?

Thanks :slight_smile:

EDIT: Will this fix it?

OSMC already includes all of the languages offline.

Try another skin.

The same happened with the original Kodi skin

I had a the same boxes problems with Minilyrics on OSMC / Raspberry pi with Confluence skin. I was playing several Japanese songs and run into the issues. After fiddling around I figured out the solution.
Go to System>Settings>Appearance>Skin

Now go to Fonts and from the windows select Arial Based (last option) that’s it. Apparently the default font doesn’t support Unicode or at least Japanese characters.

Back to Minilyrics and now Japanese display properly. Just wanted to share it if someone stumbled on this post.