Fresh Install Blank Screen after install

I’m new to OSMC. I just attempted my first install using the Windows installer from the OSMC downloads. I have a Raspberry Pi B. Installed to a 4GB SD card with no problem answering all the questions and selecting WIFI connection with all the connection info. Got the initial installing screen, then rebooted, got the OSMC splash screen. Then black. The WIFI dongle I have attached was going nuts but nothing on the screen. According to my wireless access point, it did connect and authenticate. Tried to SSH with putty but got “Updating APT cache. Please be patient.” So I assume SSH is enabled by default. I left it for over an hour. Tried rebooting a dozen times.
Finally, I moved it closer to my router and connected the LAN cable. Tried SSH w/ putty again, got the same message, but while I was starting this post, that changed to a prompt.
Ran …
sudo apt-get update
sudo apt-get dist-upgrade
I had about a dozen packages update. After that was complete, I reboot and was back at square 1 again. At least now I can SSH into it with no problem but I still get a black screen after the OSMC splash screen. I can now SSH even if it’s just running from WIFI so I know that’s not the issue. It’s got to be a display setting issue but I don’t know what settings to mess with.

So, slight update. Here are the links to my logs…
And about while I was still flipping through the forums still trying to find an answer, the screen went to a sad face for 5 seconds and I got kicked off my terminal session. I guess it rebooted and the wifi is going insane again. I’m going to leave it running overnight. I changed the password for the osmc account. Hope that doesn’t screw something else up, but I can’t stand the security issues with leaving something set to a default password especially if its a computer with SSH enabled.

Sounds like insufficient power issue.

I suppose that could be a problem, I’m using a really cheap cable I found sitting around. I will try a different cable, just curious what leads you to believe that’s the problem?

That’s nearly always the problem

okay, well, I feel a little stupid. Pulled out the voltmeter, tested everything, reconnected everything, turned it back on, still nothing, but I had moved a lamp closer to see the circuits so now I noticed something extremely faint on the screen. Turned up the brightness and low and behold, there’s my picture. Probably there all the time, just so faint, it looked black.