Fresh install of RC3 not booting

I ran the osmc installer (on linux fedora 21). When I put the SD card in my RPi (B+2), I get a multi-colored screen. And the RPi’s disk light doesn’t flash after that (meaning no reads/writes).

I put the SD card back in my desktop, and looked at the file listing:

[root@Elmer ken]# ls -l /run/media/ken/E41A-EA0D/
total 156919
-rw-r–r-- 1 ken ken 17900 May 20 01:41 bootcode.bin
-rw-r–r-- 1 ken ken 146 May 20 01:41 cmdline.txt
-rw-r–r-- 1 ken ken 51 May 20 01:41 config.txt
-rw-r–r-- 1 ken ken 135976092 May 20 00:01 filesystem.tar.xz
-rw-r–r-- 1 ken ken 2370 May 20 01:41 fixup_cd.dat
-rw-r–r-- 1 ken ken 24117112 May 20 01:50 kernel.img
-rw-r–r-- 1 ken ken 265 Jun 1 09:43 preseed.cfg
-rw-r–r-- 1 ken ken 568792 May 20 01:41 start_cd.elf
[root@Elmer ken]#

FWIW: I had also tried the NOOB install of RC2, but it boots to a blank screen.

Please help!


@daytooner, Standard questions:

  1. Are you 100% sure that you have a Raspberry Pi 2?
  2. I answer to 1 is “yes” have you choosen the right (Raspberry Pi 2) image in the installer?

Never heard of a RPi B+2 before…

You either have a Raspberry Pi B+ or a Raspberry Pi 2 - double check which you have and make sure you are using the correct install image.

@DBMandrake well unfortunately even so there is currently only one Pi 2 it is still a “B” as there is no “A” for the Pi 2 sofar. So some one might actually ready it as B+2. Anyhow I still believe the question about using the right image is valid.

You seem to have misinterpreted my reply - which was to the original poster. (Sometimes the forum doesn’t show who the reply was to)

You are absolutely correct, the wrong image will be being selected - I was pointing out there is no such thing as a Pi B+2, therefore the model of Pi is in doubt.

@DBMandrake, @fzinken

OK, sorry for the confusion.

  1. I have the RPi 2.

  2. I downloaded the osmc installer onto my Fedora 21 system.

  3. I ran osmcinstaller, and selected the following:
    Language: English
    Install OSMC on Raspberry Pi 2

    Version: RC3
    local build unchecked.

    Where: on SD card

    wired connection
    configure manually checked
    DNS Servers:,

    Device: /dev/sdi

    EULA: checked

  4. it grabs the image, installs it onto the SD card /dev/sdi.

  5. unmount and remove SD card from Fedora 21 box, put into RPi 2.

  6. Connect power to RPi 2.

On the TV (conncted to RPi 2 via HDMI) I see 4 rectangles, each multi-colored.

I also tried this with RC2 version. Same thing.

I removed the SD card (after the power connector) and mountd it in the Fedora 21 system. The files on the SD are as I listed above.

Nothing after that.

Can you post a photo of your raspberry or the exact text that is written on it?

Check the back side of the circuit board, if there is no chip in the middle it’s not a Pi 2.

Also try installing the Pi 1 image to see if you get a different result.

the rectangles mean there is not enough power . Are you using more then 1A ? and if not how many devices did you put in the USB ports .

I interpreted “4 rectangles, each multi-colored” to mean the full screen 4 colour gradient you see when a Pi powers on.

The low power warning is a tiny square in the top right corner divided into 4 colour squares.

OK, finally got something to install.

I finally grabbed the NOOB installer. The first time I ran it, I selected OSMC_P2, thinking that was for the RPi 2. The installer warned that it “may not” work for all OS’s. And, it didn’t work. So I retried running NOOBs, and selected the “OSMC_P1”. And, holy bits Batman, it worked. Once I connected it to my MySQL server, I finally have my full library back. There are a few quirks/differences with the OSMC skin I’m working out, but, all in all, I can now say, it’s done.

FWIW: what I tried and didn’t work:
Linux (F21) osmc installer - for RC3 and RC2.
Disk images for RC2 and RC3

Don’t know why, and don’t have time to figure out, but one would reasonably expect the first two to at least work.

Thanks for all the replies. It’s nice to know that someone is out there willing to help.


PS: Yes I do have the RPi 2, with a suitable power supply.

Sorry, but if the Pi 1 image works and the Pi 2 image does not, you do NOT have a Pi 2. Simple as that.

We don’t have the images mixed up. :wink:

1 Like


you installed and run succesfully an image for the Raspberry P1 and your are still saying

some people are really funny

1 Like

You have a Pi1 or it would not have booted

Can you take a photo of your Pi?


1 Like

Of the rear side of the board please, as the front looks very similar.

1 Like

I was bitten by the same wrong assumption as @daytooner because there is a print on the board reading ‘Raspberry Pi Model B+ VI 2’