Frustrated with my Vero 4k

After a ton of research I finally purchased a Vero 4k. However, I’ve had almost daily issues since I received it. My V4k freezes everyday. It freezes in three different scenarios:

  1. During video playback
  2. Scrolling through my video library
  3. Updating my video/music library

In each of these scenarios the screen freezes and even after waiting upwards of 5 minutes it doesn’t unfreeze. When it freezes during video playback or while scrolling the library nothing works until I unplug and reboot the V4k. When it freezes while updating either of the libraries (video/music) the screen will freeze as a single color (either orange, green, or purple).

In reading these forums, I thought I had identified the issue. I assumed it was because I had installed the Mimic skin and assumed it was caused by one of the Add-ons. So I reinstalled OSMC using an SD card and decided, I’d live with the standard Kodi skin. So I reinstalled OSMC. Backed it up and then checked for updates.

My V4k seemed to work for a full day without freezing. Then the freezes began again. Maybe it wasn’t an Add-on after all?

I came back to these forums and dug around some more. I identified that it might potentially be the power supply. So I attempted to plug the V4k directly into the wall socket (not in a power strip as it was previously) to see if this fixed things. It did not. My v4k freezes every few hours and I’m very frustrated.

I’m sure you’ll all ask me to create some logs and upload them. Is there any hope this device will be rock solid and simply work?

Of course! You are assuredly an exception, not the rule. We look forward to receiving your logs so that we can have a look at what the problem might be!
I can provide the link if you need direction on how to provide them.


Why not provide the link anyway? :wink:

1 Like

My finger was sore from pressing it so often today already :point_down:


:joy::joy::joy: glad that I could’ve been of help then…


Hi Jason,

Firstly – I’m sorry you are not happy with the Vero 4K. As others have commented however, this isn’t something to expect. I am sure you purchased the device on the merit it has received and didn’t expect to encounter this kind of problem.

The current reported failure rate for Vero 4K is 7 per 5000; and the power supply is slightly more prone to failure at 16 in 5000.

Unfortunately, failures have to happen to someone. We analyse every device returned and see how we can reduce the incidence of failure in the future.

I would normally suggest a complete reinstallation of OSMC, but if your device is displaying random colours then this is usually indicative of a hardware problem.

My suggestion is to reinstall OSMC once more (latest version from the website) and to just use the library without add-ons for 24 hours. If you still experience a problem, send us an email to and we’ll swap the unit over for you. If you don’t, then we have a starting point.



1 Like

Thank you for the quick response. I uploaded the log of a crash I was able to replicate during a library update.

You would need to share the URL displayed

Sorry. Here they is the one with the error: REMOVED

edit: removing incorrect log. locating other one and will post.

It needs to be a debug log.


This should be a debug log from an error captured from the #3 scenario of an error occurring during a library update which results in a solid color screen freeze (purple).

It’s still not a debug log so it’s not possible to tell what’s happening.

Are you able to hear the menu sounds after this happens? If you are, then it sounds like an HDMI issue.

Failing that, it’s likely to be the power supply. For good measure however we can swap the unit and PSU over


Hi Sam,

Not able to hear any sounds after the freeze. The OSMC completely freezes leaving the screen as shown (in this case purple).

I enabled the logs per OSMC the instruction here:

Before uploading any logs, you should ensure that Debugging is enabled in Kodi. This can be done by going to Settings -> System -> Logging -> and selecting Enable Debugging. You should then perform a reboot of your device and perform only the minimum actions required to replicate this issue so that it is easy to identify the cause of the problem.

After rebooting, I replicated the error which then froze the OSMC. After remove the power (thus rebooting), I then uploaded the kodi.log.

I also attempted to upload using “My OSMC” which uploaded successfully but I didn’t jot down the URL.

If there is something I’m missing in this process, then please let me know.

I’ll retry.

Hi Jason,

Probably won’t help. I’d suggest just trying quickly on a different display in another room. If you still get the same problem email and we’ll handle it there.


Hi Sam,

Taking your advice, I tried it on a different screen in a different room. It crashed again trying to update the music library. So I reinstalled the OS once again and now have taken to updating my FLAC IDTags to ensure there isn’t a bad tag causing Kodi to crash. I do notice that after it crashes the OSMC is hot to the touch.

I’ll try enbabling the debug log again before trying to update the library. If these actions don’t work, I’ll email and see if I can swap the unit.


Thanks for your reply. It certainly sounds like a swap might be the best course of action here.