General unreliability and endless sad face loop

I have two rPi set up for the children and they are having some issues.

They started getting sad face reboots after we suffered a few power cuts over summer. Stupidly I neglected looking at them properly and simply rebooted them over and over until they came back and then said I would look at them properly another time.

Well, now one of them wont boot at all, just a page of text of the OSMC splash screen followed by a sad face over and over. I have tried about 30 or 40 times and no luck. The other one I can get to boot every now and then.

My plan was to get the one that does sometimes boot up and running, update it (this has been neglected too), do a backup of all of their customised interface, and transfer it to the one that doesn’t boot at all.

However, I cannot even update the one that sometimes boot. All I get is a message saying addon failed.

I didn’t know what logs would be needed, so I did the lot.

https://paste.osmc.tv/kosesaqaxu

I really don’t want to lose their UI customisations because I don’t have a backup and I don’t remember what I did.

Well the easiest way is get a new SD Card, do a clean install of OSMC on it and then connect a SD Card Reader with the old card to it that allows you to retrieve all your files.

Second option as Sad Face just means Kodi (UI) is crashing you should still be able to access command line via SSH that also allows you to retrieve all files.

Details regarding how to access the command line interface can be found here on our Wiki: https://osmc.tv/wiki/general/accessing-the-command-line/

Last but not least you have Overclocking configured I would remove that for a more stable system

arm_freq=1200  
core_freq=400  
sdram_freq=400

Sometimes it just boots to this.

I don’t know why the overclock settings are like that, I don’t recall doing it.

As written either do the SSH approach or the second SD install

Installed from scratch, rebooted to sad face cycle.

The other (sometimes boots) install allowed me to run the update (after another few reboots), however this failed also.

ERROR occurred installing package: e2fsprogs (1.43.4-2+deb9u2) something flashed up saying “out of bounds” or something.

I’ll go back to the fresh install and try again.

Get a new power supply also assume you used a new SD Card! Maybe test the SD Card first with H2Testw

I’m using a different power supply as I am at work. I don’t currently have a spare usable SD card, can I do a USB install for now just to try it?

Feel free while from a power requirement that is even more challenging

OK, so I found another SD card and have a clean install working again.

Now I need to get the configuration transferred across. How do I do that?

Plug the old SD card into a SD Card reader and connect it to OSMC.
You could then use the File Manager to transfer but it would be more save to login via command line (SSH) and just do the adaptations manually.

Not really sure what to copy to be honest.

Well depends what you what to take over.
Check
<path to old sd>/home/osmc/.kodi/userdata/sources.xml
<path to old sd>/home/osmc/.kodi/userdata/guisettings.xml
and potentially
<path to old sd>/home/osmc/.kodi/userdata/advancedsettings.xml

If you are sure that all old files are still ok you can also copy the whole <path to old sd>/home/osmc/.kodi folder from the old SD Card

Yeah I tried the guisettings.xml as assumed that would do the bulk of it, but it just rebooted exactly the same, with the file size back to standard. It’s like it just got overwritten at boot.

You need to stop mediacenter before you replace the file
sudo systemctl stop mediacenter

Ok, I’ve done that.

I don’t know how to copy files using command line though, I was using file manager.

cp <path to old sd>/home/osmc/.kodi/userdata/guisettings.xml /home/osmc/.kodi/userdata/

Is there a trick to finding out the path? Nowhere in Kodi is telling me.

I have even copied just the guisettings.xml file onto a blank usb drive, and I still can’t work out the path as there is no reference to it anywhere. All I can find is the drive name.

it will be under media.
You can do ls /media/ to see what is automounted