Generally bad experience after 17 update

Hey guys, has anyone else just been having problems across the board after the 17.0 update? I’ve been using OSMC on my Rpi 2 for a long time now and I love it, but after the update I’m having the following issues:

  1. Updating library causes the system to hang up and freeze once it starts searching for new TV shows
  2. XBMC Alarm clock no longer works
  3. I use simpleIPTV client to stream tv from the encoder system where i live. It has become super slow in changing channels and initializing. When you start to play a stream it starts minimized and you need to back out a couple of times to get it to play fullscreen despite having the option selected for full screen in the options.
  4. 1 out of 10 times when i start to play a file (both a local file (harddrive) or a network file (NAS) system will freeze and require a restart or will just hang up for a long time (5+ minutes).

These are just a few issues that i can think of right now, and these things worked flawlessly in 16. Think the update just went bad for my setup? i’d like to avoid a fresh install if at all possible, but if this is isolated to just me i guess i have no options.

1 and 4 could possibly be caused by a weak power supply. Can you check the rating of this power supply and let us know how many amps it supplies.

Is the XBMC alarm clock a separate addon? This could just be disabled and needs to be re-enabled but it could be that this addon is not fully compatible with Krypton yet.

What does the simpleIPTV developer say about Krypton? Do they say it should be supported properly on Krypton?

I’m using this wall brick

along with an new Anker micro USB cable. So it’s coming in at 2.4a if needed.

XBMC alarm clock is an addon, i’ve tried uninstalling and reinstalling, but it has the same effect, doesn’t seem to want to work.

I haven’t looked into investigating the SimpleIPTV dev yet, since it shows up on the main OSMC menu as Live TV i figured it was OSMC having a hard time handling it and not the pluggin, maybe i’m wrong on that one.

Regarding what @jb2cool wrote about power supplies, and what you wrote about yours:

Cool, can’t hurt. Just bought one…lets hope it helps. Does OSMC no longer do the little Rainbow square in the corner of the screen to show the power isn’t sufficient?

Nope, there’s lightning symbol now :wink: But it’s not the only symptom of bad PSU, and as it was written here maaaany times before - a charger is not a proper power supply for RPI.

Awesome, ok i hope this new PSU works, it’s become…tedious using OSMC lately with all the issues i’m having.

Grab a power supply from our store and you’ll have absolutely no issues

just bought one from you guys

Alf course you may still have issues but they will certainly not be power issues.

This is the first place to start at least.

Great – it’ll be out for you tomorrow morning.


yea, i’ll check back in once the PSU shows up issues or not

It looks much slower when making network requests.

Also have a raspberry pi v2.

17 was rough for me in the beginning too. Actually ended up wiping my SD card and doing a fresh install, but after changing back to my preferred theme, things have been very nice. More stable - used to have weekly lockups mainly after/during watching older content, haven’t seen any since loading v17.
$ uptime
07:34:40 up 15 days, 22:11, 1 user, load average: 0.17, 0.24, 0.25

LiveTV - using HDHR4 tuners here and haven’t noticed any issues, but we honestly don’t really watch live TV much. Just the major, sporting events. The schedule and tuning works using the standard addons for HDHR equipment.

I have seen more “network is slow” warnings when streaming from the household Plex server (running PlexBMC), but the stream itself hasn’t been an issue. Haven’t done any more research on this. The Pi is wired into a GigE network. Don’t really stream content off the internet much, though youtube streaming (tech podcasts) is working fine.

Many people use a powered, 4-port, USB2 hub for power to their Pi with external storage devices connected. USB2 disk performance is sufficient for common, local, hidef, video.

Would also say that a few addons aren’t working, but most are. Gotta give the addon teams time to catch up. I need to check out the alarm clock one mentioned above. Could be handy.

Anyway, just wanted to share my positive experience on the same hardware running v17.

So here’s an update:

My new power supply came in the mail and there really is no difference all the issues I was having are still here. I had a RPI3 running retropi so I decided to use a new sd card and do a fresh install and run it on that. Everything immediately was better. Alarm clock worked again, IPTV is flawless, media scans don’t hang up even some other apps that haven’t worked in a while are working again for me. I’m guessing my old install got a little corrupted (?) I am having issues when the meta data isn’t correct and it asks Archer (1965) or Archer (2009), selecting the correct title doesn’t fix all the data like it used to. But over all the experience is much better!