Get Wifi USB-Adapter with 148f:761a (TP-Link T2UH) working in OSMC


first of all, I searched the forum for similar topics. But i could not find any definite statements. Can anyone confirm, that you can get a TP-Link T2UH (lsubs shows 148f:761a) working in one of the newer OSMC-Images (actually mine is 4.3.3-3)? If yes, what is needed to do? I tried a lot of different things but nothing worked out for me. Tried it with integrated mt7601u driver but it seems to need a mt7610u. Any help of how to get it work or a definite statement that it is not possible would help me a lot. Thanks!


I have been unable to get the MT7610u dongle working for now

If possible, get a different one


OK thanks! I will send it back. Is there any well working 5 GHz AC USB-WLAN-Stick supported by OSMC?

Most 8812au chips work well.

We have manufactured our own 802.11ac dongle which supports tethering and it will be on the Store in a week or so once we approve engineering samples.

Other users can probably weigh in on good dongles in the interim.



It took longer than expected, but our 802.11ac WiFi dongle is now available. See We will be holding that price until the end of the month.


I’ve just bought the TP-Link T2UH. I was not thinking much, I’ve seen Linux driver on their website I thought it would work… Should I return it or is it now working ?

Try it and see.

If I open it , I cannot return it. I’ve just been plain stupid in not checking before buying. I found that there is a modified driver on github but I don’t really know what it means nor how to use it… ?

Based on that do you people think I should just return it or will it probably work? Seems stupid I know but I would be mad if I opend the box test it and cannot get it to work. 30euros lost just like that…

It might work, but we can’t guarantee it. If there’s a VID/PID miss then I can add support, but it wouldn’t be available until OSMC’s February update at the earliest now.

I want to support as much hardware as possible but won’t recommend something unless it’s guaranteed to work.

30 euros seems a little high for an MT7610U device.


They would not give me my money back so I just decided to try!

It worked out of the box but I could not connect. After some research I found that I had to disable the integrated wifi of pi 3 with dtoverlay=sdhost .

Still, it only shows 5.0Ghz Wifi while the dongle should show both 2.4 and 5.0. Not that this is much of a problem but would another driver help? (I am using a TP-Link T2UH as stated before)

If you can find a more suitable driver, then let me know. I don’t think there is one for these old devices.

Well I’ve seen this one:

I just don’t have the least idea how to try it. Or if it is even not already included… I am a 1 month noob in linux world… Trying my best to learn , nevermind I’ll figure it out.

I assume you tried rm /lib/firmware/mt7610u.dat and reboot first?

Has anything related changed in last update? The dongle has been working flawlessly for month now and suddenly it simply doesn’t work anymore. No wireless found…

Noting has been changed recently

That’s weird… Suddenly I have no wireless internet. I’ve had to comment out dtoverlay=sdhost to get the original wifi back to see if something was wrong. I really have no idea why it won’t work. I had not installed anything myself since it happened to work out of the box… I’ve tried rebooting and lsusb shows the device

Here is the log , I don’t know if that can help: