Getting all the outputs to work via xorg.conf editing

Greetings everyone, congratulations on making an amazing piece of software for an amazing platform. You’ve surely answered a ton of prayers for fellow Apple TV Users who feared the platform was dead after Kodi dropped support following Gotham.

Anyway, I’ve come with a rather pressing question- a variation on a tune that I’m sure you’ve heard countless times before from people who are having a hard time using the composite video outputs on the ATV or are using old HDMI TV’s that have a hard time giving OSMC a good handshake. You see, the TV I want to use my Apple TV with has a problem with either input method, 1) it has no native HDMI input so I have to use an HDMI > DVI adaptor (which completely destroys any chance of getting good EDID information) or it has composite video inputs. Yet you see, being able to use both types of outputs (not at the same time) is absolutely ancillary for me because I don’t just use my ATV with this one TV for watching stuff at home, I’m actually a Visual artist who also uses it for installations as well.

Previously I had fireflash or whatever that guy who was charging $ to make USB installers of OpenElec for the ATV called himself, that installed gotham on my box and life was good - I could take it anywhere and plug it into anything and it just worked. Wow. However as time passed, for someone who really appreciates aesthetics I grew tired of confluence and the limited skins / styles available for that older version of XBMC, but I really fell in love with the graphics of OSMC~

Long story short, I’ve tried pretty much all the recommended tweaks I’ve found here when it comes to editing xorg.conf to make x11 go back to behaving that way- first I’m not sure if the recommendation found on the Wiki is supposed to completely replace the contents of the xorg.conf file or just sit underneath it. Of the configurations I’ve tried there is inserting the options below as aforementioned, or this one guy on youtube seems to think inserting them manually at certain places is the way to go.

In the long run neither method has worked, and I’m now debating ponying up again for that fire-whatever so I can briefly install whatever the latest version is, and then cp it’s xorg.conf file so I can use it with this incredibly nice distro later. In the end if someone has a configuration that I could copy with lots of options and a component out that’s confirmed working I’d really appreciate it.

To briefly cover the symptoms, the TV I’d like to use it with can show a splash screen over either component or HDMI > DVI for a few scant seconds, but then it’s nothing but darkness from there on out. I can bring it into the livingroom and it works over HDMI with my dad’s TV but he gets a bit cross at me if I do that constantly.

Thusly, to sum it all up, I’d like to use this Apple TV with every type of setup imaginable because I know it’s capable of that- I would have never believed it the day I pulled it out of the trash, but since then for something that’s effectively cost me nothing it’s worked miracles, and with it’s analogue outputs it’s been able to go places where my well off contemporaries with their expensive mac Mini’s couldn’t even dream of going! With your assistance there’s got to be a configuration that can make OSMC deliver this robustness, and I’m very appreciative of your help.



FireCore is quite old and installs XBMC on the OS X based OS, Frontrow. It won’t be up to date now.

You can use something like this for Component:

# nvidia-xconfig: X configuration file generated by nvidia-xconfig
# nvidia-xconfig:  version 295.40  (  Thu Apr  5 22:33:07 PDT 2012

Section "ServerLayout"
    Identifier     "serverlayout0"
    Screen      0  "screen0" 0 0
    InputDevice    "Keyboard0" "CoreKeyboard"
    InputDevice    "Mouse0" "CorePointer"

Section "InputDevice"
    # generated from default
    Identifier     "Keyboard0"
    Driver         "keyboard"

Section "InputDevice"
    # generated from default
    Identifier     "Mouse0"
    Driver         "mouse"
    Option         "Protocol" "auto"
    Option         "Device" "/dev/input/mice"
    Option         "Emulate3Buttons" "no"
    Option         "ZAxisMapping" "4 5"

Section "Monitor"
    Identifier     "monitor0"
    VendorName     "SNY"
    ModelName      "Sony TV"
    Option         "DPMS"    

Section "Device"
    Identifier     "device0"
    Driver         "nvidia"
    VendorName     "NVIDIA Corporation"
    Option         "RegistryDwords" "RMDisableRenderToSysmem=1"
    Option         "DynamicTwinView" "false"  
    Option         "ModeValidation"        "NoVertRefreshCheck, NoVesaModes, NoXServerModes"

Section "Screen"
    Identifier     "screen0"
    Device         "device0"
    Monitor        "monitor0"
    Option         "DPI" "100x100"
    Option         "UseEvents" "1"
    Option         "AddARGBVisuals" "1"
    Option         "AddARGBGLXVisuals" "1"
    Option         "UseDisplayDevice" "TV"
    Option         "TVOutFormat" "COMPONENT" 
    Option         "TVStandard" "HD1080i” 
    Option         "TVOverScan" "0.80"
    Option         "NoLogo" "True"
    Option         "Coolbits" "1"
  SubSection     "Display"
        Depth       24
        Modes      "720x480" "1280x720" "1920x1080"   
Section "Extensions"
Option "Composite" "Disable"

I suspect that because you are not getting good EDID information, HDMI isn’t being activated. It’s possible to dump an EDID.bin which matches your TV and reference that in Xorg.conf.


Hi Sam,

Thank you for your reply and all the work you’ve done on this amazing product, along with making all of the CrystalHD stuff possible in the past too!

I copied all the code in your reply to the xorg.conf file on my apple TV, after making a backup of the original; however I still can’t get it to display out using the component video connections. I can still get a glimpse of the boot sequence and the OSMC splash screen over either connection, but after a few minutes all I’m seeing is black.

I’ve decided to kind of give up for now, it’s getting a bit stressful; my best guess after making so many edits to xorg.conf is that something else must be causing this problem but I wouldn’t even know where to begin looking. The system is on and I can SSH into it, but unless it’s plugged into a modern TV over HDMI I just can’t see any of what it’s doing.

I’ll try to check in with subsequent releases of OSMC to see if the situation improves, it’s worth noting that with this old openElec guide I was able to get it to consistently display a sad face over Component which I guess is an improvement. I believe there’s potential here but I’m just not able to realize it now for whatever reason.

Much obliged,


Kodi is X11 based. This suggests that X11 is not being sent over Component.

A sad face is drawn by ply-lite in the framebuffer, not X11. The sad face was likely being generated because X11 couldn’t start with your Xorg.conf.

Not played with dual output before. I’ll see if it’s possible on the legacy drivers.