Glitch navigating through menu - video signal lost

On a Vero 4k+, something odd has started happening.

As scroll through a file menu of videos on external hdd,
the TV loses video connection over HDMI and I need to reboot the vero 4l+

Here is a video of what happens

Upload logs via MyOSMC - Log Uploader and share the URL.

Did you check the HDMI cable?

Is the external drive powered?


  1. The external drive is an SSD powered by the USB port
  2. The HDMI cable is the one I received with the Vero unit
  3. I am not a techie and have no clue where the logs are
  • I have no clue how to SSH into anything with my Macbook

The problem does not happen while watching shows

Settings - MyOSMC - Log Uploader

Here is the log file

Thank you for your help.

This is getting annoying.
Last night I watched movie via Vero 4k+, I turned off the TV and went to sleep
This morning, I turn on the TV and try to access Vero 4K+ and it had crashed - no HDMI signal and I could not access it via my network.

To get the device working I have to unplug the power and then plug it back in to reboot

The last entry is
2021-10-17 21:23:21.987 T:2788 INFO : CAESinkALSA::Initialize - speaker layout 0

This seems to be about the time when I turned off the TV

I have never had a media player that crashed as often as does the Vero 4K+

I tried to watch something on Vero 4K+
I stopped the video and got the circle of dots thing
Then I got No Signal on HDMI

If it helps
TV = Samsung QN55Q8DTAFXZC
connected to HDMI 3 which has eARC

Kinda sucks that everyone can see in the log files what I am watching.

Seems common problem iin last two crashes

2021-10-17 21:23:21.985 T:2788 INFO : CAESinkALSA::InitializeHW - Your hardware does not support AE_FMT_FLOAT, trying other formats
2021-10-17 21:23:21.985 T:2788 INFO : CAESinkALSA::InitializeHW - Using data format AE_FMT_S24NE4

2021-10-18 09:01:40.318 T:2775 INFO : CAESinkALSA::InitializeHW - Your hardware does not support AE_FMT_FLOAT, trying other formats
2021-10-18 09:01:40.318 T:2775 INFO : CAESinkALSA::InitializeHW - Using data format AE_FMT_S24NE4

Can you please turn on debug logging in Settings-System-Logging. You may have to set the settings level (bottom left) to Standard. Full instructions below.

There are two issues here

  • no signal when trying to play Muhammad Ali (or did you not press Play or OK?), and
  • no signal after TV is turned back on

The second one has been reported by others. While we are working on that, try turning off the screensaver (Settings-Interface-Screensaver) and turning on HPD lock (Settings-System-Display-Lock HDMI HPD and re-boot).

For the first one, we need debug logs taken after you have tried to play a video. Does it happen with other videos?

To get a better understanding of the problem you are experiencing we need more information from you. The best way to get this information is for you to upload logs that demonstrate your problem. You can learn more about how to submit a useful support request here.

Depending on the used skin you have to set the settings-level to standard or higher, in summary:

  • enable debug logging at settings->system->logging

  • reboot the OSMC device twice(!)

  • reproduce the issue

  • upload the log set (all configs and logs!) either using the Log Uploader method within the My OSMC menu in the GUI or the ssh method invoking command grab-logs -A

  • publish the provided URL from the log set upload, here

Thanks for your understanding. We hope that we can help you get up and running again shortly.

OSMC skin screenshot:

The first one with Muhamad Ali, it was not a video but a folder.
I was not entering the folder just passing through it to the next file when it crashed
but it has not happened again