Golang upgrade

I tried to update Golang to install sselph’s scraper for EmulationStation but I’m still stuck to 1.3.3
osmc@OSMC:~$ go version
go version go1.3.3 linux/arm

I tried :
wget https://storage.googleapis.com/golang/go1.8.3.linux-armv6l.tar.gz
sudo tar -C /usr/local -xzf go1.8.3.linux-armv6l.tar.gz
export PATH=$PATH:/usr/local/go/bin

A little help will be greatly apreciated :slight_smile:

You should have placed /usr/local/go/bin at the front of $PATH, so it would be picked up first. ($PATH is searched from beginning to end (ie left to right), and the first matching executable is run.)

Could you be more specific ?
I’ve edited /etc/profile and put export PATH=$PATH:/usr/local/go/bin at the end or the bottom : no changes.
I’ve edited .profile in $HOME and put export GOPATH=$HOME/go at the end or the bottom : no changes.

About what? I’ve explained the way that $PATH is searched from left to right.

You can see which version of go is being used by the command which go. If it’s not finding the newly installed version, you should type echo $PATH to see what your PATH looks like.

Which means that you didn’t follow the direction in my first post, since /usr/local/go/bin has once again been placed at the end of $PATH. It would also generally be better to place this in /home/osmc/.profile.

As manifestely I don’t know how to write the path.
I have copy the new go on the older go.
osmc@OSMC:~$ which go

I tried to put in /etc/profile /usr/local/go/bin at the very beginning of the path but no results

osmc@OSMC:~$ echo $PATH

Install it properly in /usr/bin.
Or set PATH manually when invoking

ok I’ve put export PATH=/usr/local/go/bin:$PATH
so now go version is 1.8.3
thank you Dillthedog and Sam