Google Drive not playing

I’ve got a google drive where all my Plex content is stored, this is also accessible from the Vero. I have sometimes played content direct from the drive and had no issues, it will even pick up a subtitle file if there. All good.
In the last couple of days however, they just won’t play at all, small files or big files, different codecs - nothing will play. If I open Plex on the Vero though, everything that failed before will play no problem. I can also play things from the google drive on my iPhone with no issues.
Not sure if this change happened after the last update. Any ideas?

Here’s a log

https://paste.osmc.tv/ifoguvegaj

First log was empty, here’s another. One film did start to play but others failed.

https://paste.osmc.tv/rejekezufu

The second log is also empty.

I don’t have much experience of Plex but know that it’s a client-server system. Reading your original post I don’t really understand what your set-up is. For example, where is the server?

Google Drive is cloud based.

I’ve tried several logs but although I’ve followed instructions with logging, they all seem to be empty after replicating the fault.

Google Drive is the data source. Where is the Plex server?

Plex server is remote, based in Germany. No issue with Plex though, that’s working as expected. It’s playing from google drive that is a problem although this usually works.

Can you upload a log showing a playback attempt from Google Drive? It looks like you’re not selecting ‘All Logs’ when uploading the logs.

Also make sure that debugging is enabled

Sam

Sorry, been away for the week. Ok here’s the log where I tried 2 files and both failed.

https://paste.osmc.tv/olokicasiq

Now also getting the message ‘Plex playback failed!’

This is odd since Plex isn’t running and so I’m not trying to use Plex to play it in this instance.

I think there might be a network connectivity issue if you’re also experiencing an issue with Plex. Either that or Plex is failing to play anything via Google Drive and the warnings are related.

Have you checked the Google Drive post on Kodi forums? https://forum.kodi.tv/showthread.php?tid=324784&page=69. From what I can see, the add-on may simply need updating

Sam

Hi Sam and Team

Just an update on this. The link you sent does indeed talk about my issue, it seems google have altered the api permissions in some way.
I only wanted to be able to download from my google drive to my vero connected hard drive without having to disconnect the drive and using a pc in between to transfer.
Is this another way I could do this?

https://rclone.org/ should do the job

To use Rclone, am I right I’m assuming that I still need to use the laptop to issue these commands?
It’s not a program I can install on the Vero?

No, surely the idea is to install it on the Vero.