GUI stutter after several days of idle


Generally the Vero4K is working well.
I have an issue where the GUI performance is slowly degrading over time.
After 2-3 days it can become noticeably choppy, and after a week or so annoying to use. When it’s really bad even videos can have the occasional stutter.

A quick reboot has it back to it’s snappy self.
Although it’s not a big deal to reboot every once in a while, perhaps there is another kind of solution?


To get a better understanding of the problem you are experiencing we need more information from you. The best way to get this information is for you to upload logs that demonstrate your problem. You can learn more about how to submit a useful support request here.

Thanks for your understanding. We hope that we can help you get up and running again shortly.


I’ll wait for a couple of days for it to become laggy, grab a video of the behavior and the logs as well and check back.

If you want to enable debug logging without the onscreen display add <loglevel>1</loglevel> to advancedsettings.xml instead of <loglevel>2</loglevel>

Might be the mali getting stuck in a lower state; although it would be odd.

Which skin are you using?
Might also be worth checking system load and memory when it happens again.

I didn’t change anything. Just the default skin OSMC comes with.
I just rebooted yesterday, so I’ll grab all the info in a day or two.


Well, it’s been a while, I grabbed 2 videos of the running system.

  1. Stuttering and jerky performance after running for several days:

Everything smooth after reboot:

Uploading a log is quite tough. It can take 1-2 days to become jerky, and turning on the logs makes the system unusable because of the log output to the upper left corner.

noticed the same thing but with a more demanding skin (Xperience1080). Didn’t report this yet as i thought it would be skin related and did not bother me that much.

Btw, restarting the whole system is not necessary, it is enough to restart kodi (atleast for me).

(SSH: sudo systemctrl restart mediacenter)

Thought about just adding a cronjob at 5am to do this every day.

This is just a workaround… It’s obviously better to see what’s wrong and fix it.

You can log in via SSH and upload the log using grab-logs -A even if the GUI is sluggish.

Problem is not GUI is too sluggish to grab the logs. Problem is enabling logging turns on system info output constantly on the screen. Hard to use the system this way for a couple of days.

You can enable debug logging without the screenoverlay as fzinken posted above:

Sure its a workaround but since nobody else yet reported anything like that i thought it would be skinrelated. Will do some some testing now and see if i can find out more if i have the time.

Missed that.
I’ll enable it and grab logs.

Next time it happens the debug logs will be helpful.

By the way, I’ve been meaning to update, the situation hasn’t improved one bit with Vero 4K+. It’s pretty much the same.

If you recall, I had sent you the logs via email before booking the 4K+.

It might be difficult to retrieve the logs after this time. Do you have the ticket # at hand so I can check?

Did you restore a backup from the 4K to the new 4K +; or start with a fresh installation?


Restored a backup.
I didn’t open an official ticket, it was in an email discussion whether the new Vero 4K+ might improve on the issue a little.

The title of email is Re: Order 19072, and it was sent on Aug 11.


Thanks – explains why I couldn’t find it initially.

I’d be inclined to start fresh; just in case it’s caused by a problematic add-on or setting