Hangs on Playback

Logs http://paste.osmc.io/azucirofuq

A few days ago I updated to the latest version on my Vero 2
Since then, every movie or show I watch hangs for a few seconds then goes but without sound.
If I rewind a few seconds everything is back to normal.

This happens once every half hour or every five minutes, on a h264, hevc, divx doesn’t matter.
One weird thing I could find, for the time of the hang, one core is at 100‰

Thought it was my setup, but today I did a fresh install and just added the videos to my library and the same thing happened again

Take care

Have you tried a file that worked before?

Do you have any MediaInfo of an affected file?

If you fresh install, you will not be on the latest Kodi (needs an update to get XVid fixes). If this is still a problem, then it’s unlikely to be a regression.


mediainfo pastes from known working files

movie http://paste.osmc.io/eyavifelir
tv episode http://paste.osmc.io/ahiricaliw
xvid http://paste.osmc.io/tovoxifoka

All of these should play without issues.

ii  vero2-mediacenter-osmc               16.1.0-7                    armhf        Media Center package for OSMC

Seems to suggest you are not on the latest version. I think this should be 16.1.0-8.

Can you check for updates in My OSMC -> Updater?

If you still get problems can you check if Passthrough is enabled and Adjust refresh rate is enabled?



Tried the updater, no new updates available

and pass-through is enabled for my receiver (it’s DTS and Dolby compatible) and adjust refresh rate is disabled
I’ll try to change some of these options and get back to you

You should enable Adjust Refresh Rate if you are playing 23.976Hz content.

It seems I found the culprit :grin:
I’ve got a new TV with a LAN connection, both the Vero and TV are connected to the router.
It never occurred to me that the TV somehow caused the error. Well after a long weekend of trial and error I finally disconnected everything from my router and after a few episodes and movies without a hang, it’s safe to say that the network connection got somehow disturbed.

Just reconnected the TV and within a few minutes the TV episode kept on hanging.
It’s a somewhat weird issue but save to say I found it.

Take care

What TV is this?


Sony Bravia KDL 55 805c

With Android TV