Has anyone else's raspberry pi died?

My Pi was acting strangely kept throwing up a setup dialogue for the youtube addon.
So I did a soft reboot and it did the sad face forever.
So I did a hard reboot and same thing, have to find the flash card reader now.

Can you still login via SSH?

wow yes, didn’t even bother trying I figured that would be impossible, says “osmc@osmc-Tristram:” no idea what command to use to start recovering though?

Well grab-logs -A provide us the URL so we can try to help.
A quick and dirty solution.
mv .kodi .kodi_backup

well “grab-logs -A”
returned “Unable to write temporary log to /var/tmp/uploadlog.txt

I haven’t tried the other one yet, figured I might try to get the logs for you before I make things worse.

Does df -hindicate that you are out of disk space?

Don’t think so, says there’s 362M available.
“osmc@osmc-Tristram:~$ df -h
Filesystem Size Used Avail Use% Mounted on
devtmpfs 362M 0 362M 0% /dev
tmpfs 367M 5.0M 362M 2% /run
/dev/mmcblk0p2 15G 14G 0 100% /
tmpfs 367M 0 367M 0% /dev/shm
tmpfs 5.0M 0 5.0M 0% /run/lock
tmpfs 367M 0 367M 0% /sys/fs/cgroup
/dev/mmcblk0p1 240M 21M 219M 9% /boot
tmpfs 74M 0 74M 0% /run/user/1000”

Means your SD-card is in 100% use. Might want to move videos/music (if you stored it on the SDcard) from the card to an USB drive in order to make room

Run this to see which folder is using the most diskspace

du -h -d 1 /home/osmc

ok, deleted a few things, and it seems to have solved the problem, OSMC booted up just fine.
Is it safe to post the entire log? Don’t have to omit anything? Like IP address isn’t in there? Or Routers’s MAC Address?

Your public ip is not included in the logs.

Well than no need for logs as your problem was just that you run out of space. Just ensure to always keep 2G free