Hauppauge/Harmony IR random multiple presses

Hi all,
Sometime last night I noticed my Harmony remote (sending generic Hauppauge MCE RC6 commands) started randomly going wild with key presses. Although I am only pressing one button at a time, the system will randomly decide to duplicate that key press anywhere from 2 to 40 times. It happens most often with the OK/Enter key or the Back key, but it does it on all other keys too. For instance, I could be scrolling down my movies list, one key press at a time, and anywhere from 2 to 30 key presses later it randomly takes off and scrolls on its own for pages at a time. Looking at the log it’ll say things like:

DEBUG: OnKey: guide (0xe0) pressed, action is Stop
DEBUG: Previous line repeats 35 times.

Which of couse I didn’t press Stop 35+ times in a row… Or this (only pressed OK/Select once):

16:39:35.671 T:4081750608   DEBUG: OnKey: 11 (0x0b, obc244) pressed, action is Select
16:39:35.938 T:4081750608   DEBUG: Previous line repeats 6 times.
 LIRC: Update - NEW at 17978:160 0 KEY_OK_UP linux-input-layer (KEY_OK_UP)

Regular Vero remote works fine.
Then I updated last night to the latest and that version broke the IR totally, and finally updated again this morning and the IR works but is back to random multiple presses. Version March 01 is the only version that works reliably with IR for me. Using profile RC6-MCE-LIRCD, which worked fine for weeks now with no duplication until the last few updates over the last 48 hrs.

Any clue what to do besides creating my own profile with irrecord (which I would think would have the same issue anyway)? Also thought I would see



irrecord is always the best bet.

As of today’s changes, IR is back to default, and therefore back to the same state as it was in June 2017.

Has anyone else changed in your environment?


No, nothing else changed. I tried using irrecord numerous times with several different old remotes and could never get a clean recording/file. It had issues seeing the buttons, would sometimes have to press a button 15+ times before it “got it”, and even if I could get the main buttons recorded using that profile didn’t work so good (duplicate presses, or it would act like I had to double click the button to do anything). I spent hours trying different recordings or trying different profiles off lircd’s website to no avail. I finally set the profile back to the generic mce rc6 profile that comes with OSMC and it started working again. No clue what I did but I obviously jarred something loose, been fine for couple days now, thank you.
Oh, I thought I heard mention of there being a built in ir receiver in the 4K, is that true? Would be nice if the 4K had a built-in ir receiver but I didn’t see the usual ir window in the front so I figured when people say there’s an ir receiver I figured they were talking about the extender.

The Vero4k has a build in IR receiver close to the front LED cross.
Only if you want to use the Vero4k in an enclosed cabinet you would use the IR Extended that comes with it to receive the signals

Perfect, thank you. My equipment rack is not visible from the theater room so I’ll have to go play around with my ir blasters!