Having a problem streaming from ubuntu to RP3 via Samba - "Lock preferences"

As the title says i am having some problems with my newly bought Raspberry Pi 3.
Ubuntu server (Media files on this machine) user: seedbox pw: password
Raspberry Pi 3 (streaming to tv from ubuntu server)
So the problem is that i have a shared folder on my ubuntu server which i have used Samba file sharing to share. I have no problem reaching the folders i have shared on my ubuntu machine when im on my Windows 7 pc. Here i will put in the username and password and i will have access without problem. However if i try to add the exact same folder from my Raspberry running OSMC then Kodi is asking for Username and Password. I have now tried every possible login credential i have made on any of the machines and none of it is working.
My shared folder on the ubuntu looks like this in the /etc/samba/smb.conf
path = /home/videos
valid users = seedbox
read only = no
I have tried searching deep for a solution on google but it seems that people only have this problem if they are streaming from at windows machine. If anyone has an idea on why i am having this conflict i would appreciate some recommendations, thank you.

Did you use the forum search?


Have been looking through multiple articles from the search on lock preferences and noone seems to have the problem from an ubuntu media source

The first link in that search for me recommends trying to set smb1 or smb2 in the MyOSMC settings.

I don’t seem to have a samba service running only SSH server, i haven’t seen anything about adding samba service on the MyOSMC

The settings @ActionA is referring to are not under MyOSMC but just under Settings - Services - SMB client.

But if you are connecting to Ubuntu Samba Server and your Ubuntu is up to date that shouldn’t be your problem.
I would recommend to first check the logs on the samba server and if you don’t find anything there try from the OSMC command line to connect


Ahh okay, the reason i wasn’t able to find it there the first time was the “Basic, Advanced, Expert” settings in the bottom. I set it to SMB1 instead of SMB3 and it seems to be working now so thank you so much guys. Spent hours on it heh, have a nice day/evening :slight_smile:

But that would indicate your Ubuntu not being on the latest version