Having trouble installing OSMC

I am trying to install OSMC on a 4GB card through DietPi (Based on Raspbian) and using RCA cables instead of HDMI. I’ve downloaded the latest image and extracted it.

Then I wrote the image with dd command. That created a 320 mb fat32 formatted partition on the memory card. No second ext4 partition yet.

I tried booting up that card but nothing happened. Added sdtv_mode=2 to config.text, still nothing. What could be going wrong?

What model of Pi do you have?
Did you pick the right version?

I am using 3b+ and yes I did pick up the right version. The file is name OSMC_TGT_rbp2_20191118.IMG.gz which I think is the the correct one.

When I installed the image it only created one partition, when there are typically two, is it supposed be that way?

And my config.txt file in root of that first partition only had 3 parameters at default which were gpu_mem framebuffer and one more , when DietPi or libreELEC has many, could this be a problem?

I am using the same RCA cables with DietPi so the cables are not faulty.

Yes, the installer image only has one partition. After successful boot the installer image then creates the final 2 partition structure.

Could you for the time of the inital setup switch to using a HDMI connection?

Could you for the time of the initial setup switch to using a HDMI connection?

That’s the problem, i don’t have access to any HDMI display. So i cannot confirm whether the install is broken in some way or that it’s the configuration of output that is messed up.

Well you could try to press blindly ENTER to start the installation (you will see the green light flashing for action). After initial installation is done you could again try to change the config.txt.

Well you could try to press blindly ENTER to start the installation (you will see the green light flashing for action).

I tried that couple of times and there was no green light flashing and it didn’t create a new partition. I just can’t figure out what the problem could be.

Just reinstalled the image to memory card with gnome-disk-utility instead of dd and still the same result. I kind of lost hope at this point.

Update: Installed previous version of OSMC and still got nothing.

Any other suggestion?

Because I like the look of OSMC and don’t wanna get xbian which even seems heavier.

Try adding hdmi_ignore_hotplug=1 and sdtv_aspect=1 as well.

Do you see any flashing lights?

Try adding hdmi_ignore_hotplug=1 and sdtv_aspect=1 as well.

Just tried that, still nothing happened. Here is how my config.txt looks like now.


Could the order of these parameters be causing any problem?

Do you see any flashing lights?

I saw nothing on the screen, not even that rainbow colored box. It just stayed as if raspberry pi wasn’t even on.

If you’re talking about the green light on pi, that just blinked at the beginning and then it did nothing.

This is my config.txt on a running OSMC install for 3B+ which is usually using hdmi but if I boot it with no hdmi connected it displays fine through cvbs.

osmc@pi3bp:/boot$ cat config.txt

You could try installing OSMC through NOOBS instead as a work around.

Thanks for that but it didn’t work either.

This time the green light kept blinking 3 times after regular intervals, the same thing happened when i had copied DIetPi config to OSMC root. I left it on for 15 minutes and it still hasn’t created any new partition.

I think the issue might not be the video output but that the OS just isn’t loading.

I didn’t wanted to do that as i am afraid it might slow the performance somehow, but i guess i have no other option. Thanks.

If the installer runs it will generate an install.log on the partition.
If the blinking is in a particular sequence, then this may give some clues.

Just installed NOOBS lite on that same memory card with same tools. On first boot it didn’t show anything either but i did create new partitions. On second boot i kept hitting 3 on keyboard for PAL and it worked.

The only thing i did different this time was that instead of boot partition being created by dd or gnome_disks, it was done by me with fdisk and mkfs. And just copy pasted the files afterwards.

Can i do the same with OSMC? Create new partition 400MB in size with fat32 filetype and paste all the OSMC files? Could that work?

Why were those two options being used?