HDD issues

I recently formatted a hdd to a different file system for better performance (ext4). It’s been fine until now; I played a TV show which ran for 3 seconds and completely froze. I waited for a while (thinking there’s some fault tolerance in osmc) but nothing changed, so I had to do a hard reboot. My hdd since then wouldn’t mount on startup (I had to comment out the fstab line) and wouldn’t mount manually.

sudo mount /dev/sda /mnt/wd/
mount: wrong fs type, bad option, bad superblock on /dev/sda,
missing codepage or helper program, or other error

   In some cases useful info is found in syslog - try
   dmesg | tail or so.

dmesg | tail:

EXT4-fs (sda): error loading journal

This extremely frustrating and I don’t know what to blame besides osmc.

Generally speaking, sda refers to the whole device and within the device you will have created a partition, which I’d expect to be sda1.

Please run the following command and post the output:

sudo fdisk -l
1 Like

But I’ve done this before and it worked perfectly fine. Why would it show “error loading journal”? And not mount at startup?

I ran fdisk:

Disk /dev/sda: 3.7 TiB, 4000752599040 bytes, 7813969920 sectors
Units: sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 4096 bytes
I/O size (minimum/optimal): 4096 bytes / 4096 bytes

It’s possible to use the whole device, just not so commonly done.

A quick search indicates that you should mount it read-only and (temporarily) switch off journalling:

sudo mount -t ext4 -o ro,data=writeback /dev/sda /mnt/wd/

This isn’t a permanent solution but should enable us to see the state of the data on the disk.

That gives me the same error:

mount: wrong fs type, bad option, bad superblock on /dev/sda,
       missing codepage or helper program, or other error

       In some cases useful info is found in syslog - try
       dmesg | tail or so.

OSMC fried my HDD?

Please change the title of your post (if you can) because this is nonsense.
OSMC is a minimal, custom Debian install running Kodi.
If your OS fried your drive it’s because you told it to or your drive was already dying.

1 Like

My drive is a few months old, no where near dying. It’s not really nonsense. The OS was asked to play a video and froze after just a few seconds. I’m not sure if there are any fault tolerance methods employed on osmc, but clearly I didn’t see any as I had to do a hard reset. In my book that’s on osmc to be honest.

It’s nonsense. User error is my guess.
My point is, your thread title is totally unacceptable and if I was a mod I would remove it.

2 Likes

Your guess could be wrong (probably is; how on earth is that MY error??).
Well, no offense, but I don’t see anything wrong with the title. It’s quite representative of my situation. I got a near brand-new 4TB HDD fried because of this.

Ok, what’s the output of tune2fs -l /dev/sda ?

How is it OSMC’s error? Is there proof? Evidence? A log?
I still call “User error”.

this isn’t getting the OP’s problem solved

If fdisk returns the info that you posted above, then your disk is clearly NOT fried.

This was the result:

tune2fs: Superblock checksum does not match superblock while trying to open /dev/sda
Couldn't find valid filesystem superblock.

And thank you, I appreciate the support.

Sorry. I just took exception at the title of the post.

1 Like

And you’re right but we want to help @tjabban, first.

1 Like

Hmm. Please run sudo fsck.ext4 -v /dev/sda and show the output.

Title edited…

Please use more relevant and concise titles when posting threads in the future @tjabban

This is the output:

e2fsck 1.43.4 (31-Jan-2017)
ext2fs_open2: Superblock checksum does not match superblock
fsck.ext4: Superblock invalid, trying backup blocks...
Superblock needs_recovery flag is clear, but journal has data.
Recovery flag not set in backup superblock, so running journal anyway.
/dev/sda: recovering journal
Journal checksum error found in /dev/sda
Pass 1: Checking inodes, blocks, and sizes
Inode 1114113 seems to contain garbage.  Clear<y>?

What would confirming (via y) mean? (I haven’t confirmed yet)

Guys - stop trying to mount /dev/sda - Without a partition, ext4 can’t run reliably. You do that with FAT or so, on old floppies.
So - all mount commands etc. have to use /dev/sda1 or /dev/sda2 or whatever with a number at the end!
and that also applies to the mkfs.ext4 command!
Also - please post the output of “dmesg” somewhere here.

1 Like