Hdd not recognized

Oh my god…these harddrive issues seem to be haunting me. I even had a nightmare about it :confounded:

Ok in short: I have a 3,5" 3tb hdd connected via usb. Quite some time ago the enclosure of the hdd died and apperantly hdd also got messed up. Then I bought a new enclosure, formated hdd but issues still persisted: hdd sometimes not recognized, even kernel panic, I could connect to this hdd. A month ago I finally sent the hdd in, meantime I used another 2,5" 500gb one, working without problems. Now I received a new hdd in return, put it in my seperately bought enclosure and it worked! yeyyy…Until now…Suddenly vero2 doesn’t recognize my hdd anymore.
What I did was install June update…but I thought this couldn’t be the problem.
So now I suspected the enclosure to be faulty and used the original one that shipped with the new hdd…still vero2 can’t recognize the hdd…
Now I read this thread:

Could the June update be to blame??
I don’t want to have these hdd issues anymore :sob:

We now know you have a problem, but there’s nothing else to go on, even the precise details of the HDD.

  1. what sort of partition table do you have (is it GPT or what?)
  2. how many partitions, and what sort of filesystems?
  3. what about posting logs when you have it connected – might be relevant messages there (eg in dmesg …)?

I, personally, have had some rather odd failures with usb interfaces for HDDs - sometimes they remain accessible to other PCs/OS’s.

  1. msdos…should I use gpt?
  2. one partition, ext4 fs
  3. can provide logs when I’m at home, specific ones? or grab-logs -a?

Exactly, another weird thing. On my pc win10 and also ubuntu do recognize it…

Sry about the whining, it’s just so frustrating, going on for over half a year now I think.

Boot up with the drive connected, then use grab-logs -J -K to capture the system journal and dmesg then post the link here.

Bin the drive and buy a new one :joy:

That’s like throwing out the baby with the bathwater - I’ve found that it’s good enough to simply change the electronics (by using a ‘new’ enclosure)

Here’s the link: http://paste.osmc.io/sojuduhupu


sudo apt-get update
sudo apt-get install usb-utils

Does lsusb show the drive?
How are you powering the drive?

Just this:
root@vero_2:~# lsusb Bus 001 Device 002: ID 05e3:0608 Genesys Logic, Inc. USB-2.0 4-Port HUB Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub

Powered with the supplied 12V power adapter.

Unfortunately the disk isn’t being detected. Make sure it’s not plugged in to the rear USB port.

Do you hear it physically spinning?

I did, tried all usb ports without sucess. Tried 2 different enclosures now (with them hdd gets detected by win10 and ubuntu on pc), disc is spinning up normally.

I don’t get it…just tried the 2,5" one and it gets recognized without a problem.
What I can’t understand at all is how could the hdd work at all in the first place? Makes no sense to me.

I think something isn’t quite right with your setup, but it’s hard to say what.

If I had to make a guess it would be that something isn’t quite right with the enclosure.


The one that came with the hdd is a intenso enclosure. Other one I bought is a fantec enclosure with an esata port also.
Stupid question but could someone recommend any good 3,5" enclosure?

I’ll leave that one to others.


get a NAS instead :slight_smile:

No need for that but thx.

think there is good compability lists on rpi foundations wiki if your hell bent on having a hdd just for that device

Yesterday after reconnecting everything the hdd worked, later during watching a video it suddenly stopped working…

That would suggest to me a loose connection or even an unstable power supply to the drive.