HDMI audio now multichannel

Before with Kodi v16(?) I was getting my receiver showing DTS or DD etc but it now shows multichannel?
I have passthrough on and have enabled dd DTS etc but it’s not recognising that on my receiver. Has a setting changed or is there something I need to check/change?

It seems to be outputting PCM - how do I make it stop doing that and just do passthrough? I can’t seem to find any setting anywhere to do that.

NVM. Apparently it’s a ‘benefit’ of audio/video sync.

Some content like Live TV won’t let you use passthrough anymore. This is intentional.

You could enable AC3 transcoding to get the DD light. You should not hear an audible difference, although it depends how much of an audiophile you are