HDMI CEC in OSMC, some buttons not wokring


I’ve been using Raspbmc for a long time with no problems with my Panasonic plasma remote over hdmi-cec.

Now in OSMC beta 1-4 every button works EXCEPT play, play/pause, stop, forward, backward.
Not even cec-client in console registers the buttons (others works!), and it DOES WORK in raspbmc, but not in OSMC. I’ve tried both RPiB and RPiB2.

Any ideas how to go on with this? Debug in kodi does not show button presses in osmc, but as I said, works fine in raspbmc.

Many thanks for any help!

I’m not sure but I think the TV has to recognize the PI as a player/recorder in order for the transport buttons to work with cec. Does your TV have someplace to select this? Have you tried resetting the TV by unplugging from the wall and letting it sit a few minutes?

Most buttons DO work, arrows, ok numbers back etc. But NOT the player buttons play pause stop rew forward. I’ll try that but I dont think it will do any difference… :s

“Transport buttons” is the technical term for the play, pause, FF etc. button group, they will only work if the TV sees a device that uses them

Maybe the TV was to blame… It started working then switching to a NON cec hdmi output and back to osmc… Wierd! but fixed… :slight_smile: (had to find an non-cec device first :P)

I see the same on my Viera, but only for a short period after boot.
During this time my TV recognize the Pi as both a recorder and a player.
After some time everything corrects itself though and my Viera sees my Pi as a player -> the media buttons work again.

Do you have hdmi_ignore_cec_init=1 in config.txt ?

This should be there by default and prevent this misdetection of device time during early boot.

Also check in the TV’s CEC menu that the name of the CEC device isn’t changing during boot - if it is that’s a bug.