HDMI CEC issue on RPi2 with OSMC 2016.01-1 and LG TV


I just installed OSMC on my Raspberry Pi 2. Everything is fine until I try to use the remote of my LG TV to command the media center. HDMI CEC does not function. I used a Raspberry Pi 1 with raspbmc, everything worked just fine. It seems that something is wrong with RPi2 and/or OSMC (note that I also tried openelec and I have the same issue). Maybe it’s related to the libcec? I have seen a few topics similar to mine, but no clear answer. I tried to reboot the Pi, to reboot the TV. Some suggest changing cable, but as it works fine with the same cable on a different rpi, I suppose the cable has nothing to do with the problem. I sshed on the Pi and ran

osmc@osmc:~$ cec-client -l
libCEC version: 3.0.1, git revision: ce9bc98, compiled on Tue Dec 22 17:33:23 UTC 2015 by root@vero on Linux 3.14.14-cubox (armv7l), features: P8_USB, P8_detect, ‘RPi’
Found devices: 1

device: 1
com port: RPI
vendor id: 2708
product id: 1001
firmware version: 1
type: Raspberry Pi

I supose my tv should appear as a CEC device?

cec-client -m gives me tons of

WARNING: [ 3106] unhandled response received: opcode=0 initiator=e destination=0 response=1

Power cylcing the tv gives me this message :

DEBUG: [ 118690] GetPhysicalAddress - physical address = 2000
NOTICE: [ 118690] physical address changed to 2000

There’s an issue that is similar : Yet Another CEC issue · Issue #240 · osmc/osmc · GitHub

I don’t have any physical keyboard/mouse connected to the pi, so advice/comment/help is appreciated.

Thanks in advance!