HDMI-CEC suddenly stopped working

I was trying to set up GPIO remote, so I bought random IR receiver and it didn’t work. So i ordered TSOP 38238 (I hope it will work) and as I’m still waiting for delivery, in the meantime i tried to set up HDMI-CEC remote and it worked. It worked for a week, and yesterday it suddenly stopped working. I was watching something, then tried to play another movie, and while browsing library, the remote suddenly stopped working. I tried many things - restarting osmc, turning tv off and on, many times, tried to add devices again, resetting to defaults in osmc hdmi-cec section, etc. My TV didn’t find other device. What should I do? Any advice?

CEC not working can have many reasons (e.g. another HDMI/CEC device connected).
What is your TV make? Have you connected directly?
Suggest to unplug power from TV and OSMC (physical unplug) for a couple of minutes and try then.
If not working enable debugging and upload logs.

1 Like

It was working for about a week with no problems. The one thing I did before it happened was unplugging power from my satellite receiver, changing USB flash drive in my satellite receiver (I have 2 different Enigma2 releases), and then plugging it again. So it was something like connecting new device, but I didn’t even change TV source, all that happened “in the background”. I’ve restored previous configuration, so now I have previous satellite receiver connected, and HDMI-CEC is still not working - TV hasn’t found any device.


“Magic trick” helped. Thanks a lot.