HDMI-CEC working not working anymore after some time

Hi everyone, and thanks for you hard work/help. I have two Pi2 both running OSMC RC3 at home, controlling them through HDMI-CEC. HDMI-CEC works perfectly on my Samsung T28C570 but only partially on my LG 42LW4500 TV.

When my Pi hasn’t been idling for a long time, HDMI-CEC works flawlessly. However when it’s been a while (two days in my example) that I haven’t use my Pi, If I turn on my TV, change to the source to the right HDMI input, I see the Kodi interface greyed out (like it’s in sleeping mode). If I try to wake it up by pressing the usual keys on my remote, nothing happens, as if my Pi was frozen. The Pi isn’t frozen though because if I plug my USB mouse and move it, the Pi comes back to life, and the Kodi interface responds to my movements perfectly.

Please find my setup below, if I can do anything to help get this issue solved, please let me know :smile:
One thing worth noting, HDMI-CEC feature used to works perfectly on this TV (with old Pi B 512 Mb running old RaspBMC)

[quote]Device: Rasp Pi 2
Ram: 1024
Installation media: SDcard
Connection: Wired
Power Supply Type: AmazonBasics
Power specs: 2.1 mAh
Peripherals: None at the time
Storage Device: On occasion USB stick
OSMC version: RC3
Codecs: Both enabled
Audio/Video Output: HDMI
Overclocked: Yes, Turbo mode
Config.txt Extras: None[/quote]

Thanks guys =)

What are the CEC settings on your TV?

I had a problem a while ago and it was the TV that was the issue.

HDMI-CEC (Simplink as LG call it) is enabled on my TV but I don’t have any other options available to tweak it.

To check if my issue was OSMC specific, I installed OpenELEC on a spare microSD card but I experienced the exact same issue.

Since it’s not OS specific, I don’t really know what I could do to get this solved :S

You should try this

Thanks a lot, I just went through this process, I’ll report back in a few days to report whether it worked or not =)

Unfortunately it doesn’t work in my case. I wonder if this procedure isn’t conflicting with OSMC own way of dealing with this through Pi Config: In the Display submenu, there are two options: “hdmi_ignore_edid” and “store_hdmi_to_file”.

It’s very weird that it doesn’t work, because the description of the issue seems to be exactly what I’m experiencing :S