HDMI splitter does not automatically recognize Vero 4k

Hi all,

maybe someone has a hint. I have bought a HDMI splitter which automatically switch to a “new” signal. So if i turn on my Nintendo Switch or my Sat Receiver it will automatically switch to that channel. When i turn them off it should switch again to an active HDMI signal. Since the Vero4k is running 24x7 the signal should be always there, but it does not switch to it. I have connected it to channel 1 since in the handbook it is mentioned that it will automatically switch to that per default. But this does not work either.

Could it be that the HDMI signal of the Vero4k is suspended when i switch to another channel? In the past i have used the the sleep mode and the device automatically waked up once i switched on the TV. But with the new splitter it gave quite some problems therfore i have de-activated it.

Many thanks for your help.


Try enabling HPD Lock mode.

Hi Sam,

many thanks for the hint. I will try if it works.

Many thanks.


I have the same problem, but I don’t find the hdp option in settings->system->display, how to activate this option?

Make sure you have Expert settings active.

ok, I found, I have Vero 2, my problem is that I have an hdmi splitter which auto switch input when signal is detected, what I want is that when osmc go to sleep, is that hdmi signal is off, is it possible?


How are you putting the Vero 2 to sleep?


Sleep ==> when screensaver turns on, I try the official turn off screen saver but it doesn’t work because it needs vcgencmd…

vcgencmdis a specific application for Raspberry Pi.

You could turn off the HDMI signal with something like:

echo 0 | sudo tee /sys/class/amhdmitx/amhdmitx0/phy

and to restore it?

To restore it I try this: echo “1080p” | sudo tee /sys/devices/virtual/amhdmitx/amhdmitx0/disp_mode
but it doesn’t work.



echo 1 | sudo tee /sys/class/amhdmitx/amhdmitx0/phy


phy do not exists…

what I do is echo “VIC:0” | sudo tee /sys/devices/virtual/amhdmitx/amhdmitx0/disp_mode


Works for me (on vero4k, but judging by Sam’s post it should work on vero2):

osmc@osmc4k:~$ echo 0 | sudo tee /sys/class/amhdmitx/amhdmitx0/phy
osmc@osmc4k:~$ echo 1 | sudo tee /sys/class/amhdmitx/amhdmitx0/phy

Thanks Tom.

tee: /sys/class/amhdmitx/amhdmitx0/phy: No such file or directory

The Vero 2 kernel likely doesn’t have this parameter then

ok so I can turn off hdmi but not to restore it?

You should be able to set the mode back again.

I try this:
echo “1080i” | sudo tee /sys/devices/virtual/amhdmitx/amhdmitx0/disp_mode
echo “1080p” | sudo tee /sys/devices/virtual/amhdmitx/amhdmitx0/disp_mode
echo “1080p30hz” | sudo tee /sys/devices/virtual/amhdmitx/amhdmitx0/disp_mode
echo “1080p50hz” | sudo tee /sys/devices/virtual/amhdmitx/amhdmitx0/disp_mode

Hdmi stay off…